Dire Wolf(区间DP)

Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.

Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.

Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.

— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b
i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b
i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
InputThe first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers a i (0 ≤ a i ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers b i (0 ≤ b i ≤ 50000), denoting the extra attack each dire wolf can provide.OutputFor each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.

Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74
拿题思想:这道题就和我们打的游戏差不多,有n头狼,每头狼都有一个基础的攻击值,然后相邻的狼会给它提供一个附加值,所以在杀掉这头狼时会受到的伤害是狼的基础攻击值加上附加的攻击值,要使杀掉所有的狼同时让自己受到的伤害最小;明显这是一个运用区间dp来解决的问题;首先在附加值的时候,头狼与未狼的附加值只有一只狼提供,其余的都有左右;两只相邻的狼提供,所以我们可以假设在头尾各增加一只附加值为零的狼就可以使所有的狼以同情况来考虑;然后找出动态转移方程解决问题。
最终解题步骤
1)分析问题,此题是第二种模型的题,在区间内找出k并将k取出来的问题;
2)运用区间dp解题模板编写大致的内容;
3)找出动态转移方程完善编写;

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int a[205],b[205];
int dp[205][205];
int main()
{
    int t,m,n=1;
    scanf("%d",&t);
    while(t--)
        {
           cin>>m;
           for(int i=1;i<=m;i++)
                cin>>a[i];
           for(int i=1;i<=m;i++)
                cin>>b[i];
           b[0]=b[m+1]=0;     //在头部和尾部各添加一个为零的附加值,是所有狼可以一同考虑,不用单独考虑首尾;
           for(int i=1;i<=m;i++)
                dp[i][i]=a[i]+b[i-1]+b[i+1];    //给dp赋初值,每头狼带来的伤害;
           for(int i=1;i<=m;i++)           //从第一只杀到第i只;
           for(int j=1;j<=m-i;j++)
            {
                int k=i+j;
                int s=1e9;
                for(int l=j;l<=k;l++)
                    s=min(s,dp[j][l-1]+dp[l+1][k]+a[l]+b[j-1]+b[k+1]);
                dp[j][k]=s;
            }
           cout<<"Case #"<<n++<<": "<<dp[1][m]<<endl;
        }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值