[USACO08FEB]Meteor Shower S
题面翻译
题目描述
贝茜听说一场特别的流星雨即将到来:这些流星会撞向地球,并摧毁它们所撞击的任何东西。她为自己的安全感到焦虑,发誓要找到一个安全的地方(一个永远不会被流星摧毁的地方)。
如果将牧场放入一个直角坐标系中,贝茜现在的位置是原点,并且,贝茜不能踏上一块被流星砸过的土地。
根据预报,一共有 M M M 颗流星 ( 1 ≤ M ≤ 50 , 000 ) (1\leq M\leq 50,000) (1≤M≤50,000) 会坠落在农场上,其中第 i i i 颗流星会在时刻 T i T_i Ti 砸在坐标为 ( X i , Y i ) ( 0 ≤ X i ≤ 300 (X_i,Y_i)(0\leq X_i\leq 300 (Xi,Yi)(0≤Xi≤300, 0 ≤ Y i ≤ 300 ) 0\leq Y_i\leq 300) 0≤Yi≤300) 的格子里。流星的力量会将它所在的格子,以及周围 4 4 4 个相邻的格子都化为焦土,当然贝茜也无法再在这些格子上行走。
贝茜在时刻 0 0 0 开始行动,它只能在第一象限中,平行于坐标轴行动,每 1 1 1 个时刻中,她能移动到相邻的(一般是 4 4 4 个)格子中的任意一个,当然目标格子要没有被烧焦才行。如果一个格子在时刻 t t t 被流星撞击或烧焦,那么贝茜只能在 t t t 之前的时刻在这个格子里出现。 贝西一开始在 ( 0 , 0 ) (0,0) (0,0)。
请你计算一下,贝茜最少需要多少时间才能到达一个安全的格子。如果不可能到达输出 − 1 −1 −1。
输入格式
共 M + 1 M+1 M+1 行,第 1 1 1 行输入一个整数 M M M,接下来的 M M M 行每行输入三个整数分别为 X i , Y i , T i X_i, Y_i, T_i Xi,Yi,Ti。
输出格式
贝西到达安全地点所需的最短时间,如果不可能,则为 − 1 -1 −1。
题目描述
Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.
The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.
Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).
Determine the minimum time it takes Bessie to get to a safe place.
输入格式
* Line 1: A single integer: M
* Lines 2…M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti
输出格式
* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.
样例 #1
样例输入 #1
4
0 0 2
2 1 2
1 1 2
0 3 5
样例输出 #1
5
Code: (c语言)
#include <stdio.h>
#include <stdlib.h>
#include <stdbool.h>
#include <string.h>
#define MAXSIZE 10000
/*
1、输入数据
2、数据预处理
3、BFS
. 取出搜索的点
. 当前搜索的点的上下左右
. 数据合法性 边界条件 步数时间小于流星时间 该点未走过
. 终止条件 该点为-1
*/
typedef struct { //定义坐标结构体
int x, y, t, step, vis; //x,y 坐标 ; t 该点时间 ; step 走到该点的时间 ; vis 该点是否被访问
}pos;
typedef struct{
pos point[MAXSIZE]; //点
int front;
int rear;
}Queue;
void InitQueue(Queue *Q){ //队列初始化
Q->front = 0;
Q->rear = 0;
return ;
}
bool EmptyQueue(Queue *Q){ //判空
if(Q->front == Q->rear) return true;
return false;
}
bool EnQueue(Queue *Q, pos num){ //入队
if((Q->rear + 1) % MAXSIZE == Q->front) return false;
Q->point[Q->rear] = num;
Q->rear = (Q->rear + 1) % MAXSIZE;
return true;
}
bool DeQueue(Queue *Q, pos *num){ //出队
if( EmptyQueue(Q) ) return false;
*num = Q->point[Q->front];
Q->front = (Q->front + 1) % MAXSIZE;
return true;
}
int m, dx[] = {0, 1, 0, -1, 0}, dy[] = {0, 0, 1, 0, -1}; //dx,dy控制上下左右,第一个自身位置
pos ps[1005][1005];
int main(){
scanf("%d", &m);
memset(ps, -1, sizeof(ps)); //初始化所有数据为-1
int i, j, t, x, y, tx, ty;
for(i = 0; i <= 1000; i++){ //初始化所有坐标点
for(j = 0; j <= 1000; j++){
ps[i][j].x = i;
ps[i][j].y = j;
}
}
for(i = 0; i < m; i++){
scanf("%d %d %d", &x, &y, &t);
for(j = 0; j < 5; j++){ //初始化所有陨石的所有坐标的时间
tx = x + dx[j];
ty = y + dy[j];
if(tx < 0 || ty < 0 ) continue; //边界判断
if(t < ps[tx][ty].t || ps[tx][ty].t == -1) //时间判断 比记录的时间早或者没被记录过
ps[tx][ty].t = t;
}
}
ps[0][0].vis = 1; //初始化第一个点
ps[0][0].step = 0;
Queue q;
InitQueue(&q);
pos p1 = ps[0][0];
EnQueue(&q, p1); //第一个点入队
while(!EmptyQueue(&q)){
DeQueue(&q, &p1); //队列头出列进行下一个点入队或者终止条件判断
for(i = 1; i < 5; i++){
tx = p1.x + dx[i];
ty = p1.y + dy[i];
if(tx < 0 || ty < 0 || ps[tx][ty].vis == 1) continue ; //边界判断和访问判断
if(ps[tx][ty].t == -1){ //终止条件
printf("%d", p1.step + 1);
return 0;
}
if(ps[tx][ty].t > p1.step + 1){ //步数时间小于下一个点 下一点入队
ps[tx][ty].vis = 1;
ps[tx][ty].step = p1.step + 1;
EnQueue(&q, ps[tx][ty]);
}
}
}
printf("-1"); //没有结果 返回-1
return 0;
}
Code: (c++)
c语言写队列太麻烦了 所以写c++比较快
#include <bits/stdc++.h>
using namespace std;
typedef struct{
int x, y, t, step, vis;
}pos;
pos ps[1005][1005];
int m, dx[] = {0, 1, 0, -1, 0}, dy[] = {0, 0, 1, 0, -1};
int main(){
int x, y, t, tx, ty;
cin >> m;
memset(ps, -1, sizeof(ps));
for(int i = 0; i <= 1000; i++){
for(int j = 0; j <= 1000; j++){
ps[i][j].x = i;
ps[i][j].y = j;
}
}
for(int i = 0; i < m; i++){
cin >> x >> y >> t;
for(int j = 0; j <5; j++){
tx = x + dx[j];
ty = y + dy[j];
if(tx < 0 || ty < 0) continue ;
if(t < ps[tx][ty].t || ps[tx][ty].t == -1) ps[tx][ty].t = t;
}
}
ps[0][0].step = 0;
ps[0][0].vis = 1;
pos p = ps[0][0];
queue<pos> q;
q.push(p);
while(!q.empty()){
p = q.front();
q.pop();
for(int i = 1; i < 5; i++){
tx = p.x + dx[i];
ty = p.y + dy[i];
if(tx < 0 || ty < 0 || ps[tx][ty].vis == 1) continue;
if(ps[tx][ty].t == -1){
cout << p.step + 1;
return 0;
}
if(p.step + 1 < ps[tx][ty].t){
ps[tx][ty].step = p.step + 1;
ps[tx][ty].vis = 1;
q.push(ps[tx][ty]);
}
}
}
cout << -1;
return 0;
}