[USACO10OCT]Lake Counting S

[USACO10OCT]Lake Counting S

题面翻译

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个 N × M ( 1 ≤ N ≤ 100 , 1 ≤ M ≤ 100 ) N\times M(1\leq N\leq 100, 1\leq M\leq 100) N×M(1N100,1M100) 的网格图表示。每个网格中有水(W) 或是旱地(.)。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入第 1 1 1 行:两个空格隔开的整数: N N N M M M

2 2 2 行到第 N + 1 N+1 N+1 行:每行 M M M 个字符,每个字符是 W.,它们表示网格图中的一排。字符之间没有空格。

输出一行,表示水坑的数量。

题目描述

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John’s field, determine how many ponds he has.

输入格式

Line 1: Two space-separated integers: N and M * Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

输出格式

Line 1: The number of ponds in Farmer John’s field.

样例 #1

样例输入 #1

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出 #1

3

提示

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.

思路:

1. 输入数据 数据预处理
2. 遍历每一个点 对不是水坑的点和已标记的点跳过 
3. dfs
. 八个方向上寻找水坑 
. 对八个方向上的点进行判断 对不是水坑的点和已标记的点跳过
. 标记该点 继续dfs
4. ans++
5. 输出ans

Code:

#include <stdio.h>
#include <stdlib.h>
#include <stdbool.h>
#include <string.h>

char td[105][105];			//田地 
int n, m, dx[] = {0, -1, -1, -1, 0, 1, 1, 1}, dy[] = {-1, -1, 0, 1, 1, 1, 0, -1};     //八个方向的位移向量 
bool vis[105][105];			//水池数组 
int ans = 0;				//结果 

void dfs(int x, int y){

	int i, tx, ty;
	for(i = 0; i < 8; i++){		//不断寻找8个方向是否有水坑 
		tx = x + dx[i];
		ty = y + dy[i];
		if(vis[tx][ty] || td[tx][ty] != 'W') continue;		//不是水坑 和 已标记的水坑 继续找 
		vis[tx][ty] = true;									//将水坑标记 
		dfs(tx, ty);										//下个坑继续找 
	}
	return ; 
}
int main(){
	memset(td, '\0', sizeof(td));						//田地初始化 
	scanf("%d %d", &n, &m);
	
	int i, j;
	for(i = 1; i <= n; i++){
		scanf("%s", &td[i][1]);
	}
	
	for(i = 1; i <= n; i++){						//遍历每个点 
		for(j = 1; j <= m; j++){
			if(td[i][j] != 'W' || vis[i][j]) continue;		//不是水坑 和 已标记的水坑 继续找 
			dfs(i, j);
			ans++;										//水池加1 
		}
	}
	
	printf("%d", ans);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

时屿.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值