HDU-1217 Arbitrage(Floyd算法变形)

HDU-1217 Arbitrage

Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No

#include<iostream>
#include<cstring>
using namespace std;
double map[100][100],a;
char s1[31][101],s2[101],s3[101];
int m,n,i,j,k,count=1;
int main()
{
	while(cin>>m&&m)
	{
		memset(map,0,sizeof(map));//图的初始化
		for(i=0;i<m;i++) 
		cin>>s1[i];
		int n,x,y;
		cin>>n;
		while(n--)
		{
			cin>>s2>>a>>s3;
			for(j=0;j<m;j++)
			{
				if(strcmp(s1[j],s2)==0)
				{
					x=j;
					break;
				}
			}	
			for(j=0;j<m;j++)
			{
				if(strcmp(s1[j],s3)==0)
				{
					y=j;
					break;
				}
			}
			map[x][y]=a;//两种货币之间的套利
		}
		for(k=0;k<m;k++)//变化的弗洛伊德算法
			for(i=0;i<m;i++)
				for(j=0;j<m;j++)
				{
					if(map[i][j]<map[i][k]*map[k][j]) 
					map[i][j]=map[i][k]*map[k][j];
				}
		int flag=0;
		for(i=0;i<m;i++)
		{	
			if(map[i][i]>1)//判断是否拥有获利
			{
				flag=1;
				break;
			}
		}
		if(flag==1)
		printf("Case %d: Yes\n",count);
		else
		printf("Case %d: No\n",count);
		count++;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wa_Automata

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值