弗洛伊德算法A - Arbitrage POJ - 2240

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

题意:给出一些货币和货币之间的兑换比率,问是否可以使某种货币经过一些列兑换之后,货币值增加。举例说就是1美元经过一系列看不见的操作之后,超过了1美元。可以输出Yes,否则输出No

硬是去看了弗洛伊德算法,发现了一篇很好的介绍弗洛伊德算法的文章:傻瓜都能看懂的弗洛伊德算法

//#include<bits/stdc++.h>
#include  <stdio.h>
#include <iostream>
#include<algorithm>
#include      <map>
#include      <set>
#include   <vector>
#include    <queue>
#include    <stack>
#include <stdlib.h>
#include  <cstring>
#include <string.h>
#include   <string>
#include   <math.h>
using namespace std;
typedef long long ll;
#define MAXN 100005
#define INF 0x3f3f3f3f

double rate[35][35];
char str[31][101];
int n, m;

int Find(char *s)
{
    for(int i=0; i<n; ++i)
    {
        if(strcmp(str[i], s) == 0)
            return i;
    }
}

int main()
{
    int cnt=1;
    char s1[101], s2[101];
    double r;
    while(scanf("%d", &n) && n)
    {
        for(int i=0; i<n; ++i)
            scanf("%s", str[i]);
        scanf("%d", &m);
        for(int i=0; i<m; ++i)
        {
            scanf("%s%lf%s", s1, &r, s2);
            rate[Find(s1)][Find(s2)] = r;
        }
        for(int k=0; k<n; ++k)//弗洛伊德算法
            for(int i=0; i<n; ++i)
                for(int j=0; j<n; ++j)
                    if(i!=j && i!=k && j!=k)
                        if(rate[i][k]*rate[k][j] > rate[i][j])
                            rate[i][j] = rate[i][k]*rate[k][j];
       bool flag = false;
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
                if(rate[i][j]*rate[j][i]>1)
                    flag = true;
        if(flag)
            printf("Case %d: Yes\n", cnt);
        else
            printf("Case %d: No\n", cnt);
        cnt++;
    }
    return 0;
}

我好像局部变量和外部变量搞混了,疯狂RE。。。一脸懵逼,,,,,

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值