2021-03-18

c++海岸雷达解题是遇到的问题

题目

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

这样解有问题吗?

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int n,d;
struct island
{
    double x,y;
}is[1001];
bool cmp(island &a,island &b)
{
    if(a.y==b.y)
        return a.x<b.x;
    return a.y<b.y;
}
void dis(island &a)
{
    double c=sqrt(d*d-a.y*a.y)+a.x;
    double s=sqrt(d*d-a.y*a.y)*-1+a.x;
    a.x=s;
    a.y=c;
}
int main()
{
    int time=0;
    while(cin>>n>>d)
    {
        if(n==0&&d==0)
            return 0;
        int i;
        for(i=0;i<n;i++)
        {
            cin>>is[i].x>>is[i].y;
            if(is[i].y>d||is[i].y<=0)
            {
                break;
            }
            dis(is[i]);
        }
        if(i<n-1)
        {
            cout <<"-1"<< endl;
            continue;
        }
        sort(is,is+n,cmp);
        int sum=1,un=0;
        for(int j=1;j<n;j++)
        {
            if(is[j].x<=is[un].y)
                continue;
            sum++;
            un=j;
        }
        time++;
        cout<<time<<" "<<sum<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

flww*星火燎原

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值