Catch That Cow

该代码实现了一个算法,用于计算农夫约翰从位置N出发,在两种移动方式(步行和瞬移)下,到达位置K抓住逃牛所需的最短时间。如果N大于等于K,则直接输出N-K作为时间;否则,使用广度优先搜索(BFS)策略遍历所有可能的路径,找到最短步数。最后输出这个步数作为最短时间。
摘要由CSDN通过智能技术生成

Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

#include<stdio.h>
#include<string.h>
struct note {
	int x;
	int step;
};
int main() {
	struct note que[100005];
	int book[100005];
	int next[4][2]= {{0,1},{1,0},{-1,0},{0,-1}};
	int head,tail;
	int i,j,k,n,m,startx,starty,q,p,tx,ty,flag;
	while(scanf("%d %d",&n,&m)!=EOF){
		if(n>=m)
		printf("%d\n",n-m);
		else{
		memset(book,0,sizeof(book));
	head=1;
	tail=1;
	que[tail].x=n;
	que[tail].step=0;
	tail++;
	book[n]=1;
	flag=0;
	while(head<tail) {
		for(k=0; k<3; k++) {
				if(k==0)
				tx=que[head].x-1;
				else if(k==1)
				tx=que[head].x+1;
				else
				tx=que[head].x*2;
			if(tx>=0&&tx<=100000&&book[tx]==0) {
				book[tx]=1;
				que[tail].x=tx;
				que[tail].step=que[head].step+1;
				tail++;
								
			}
			if(tx==m) {
				flag=1;
				break;
			}
		}
		if(flag==1)
			break;
		head++;
	}
	printf("%d\n",que[tail-1].step);	
		}
			
	}
	
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值