As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
暴力解法:考虑到数值不大直接dfs,再将获得的结果存在两个容器(一个装路径长度一个装救援队数量--下标一一对应)中,根据最短路径所确定的下标锁定最大救援数量。
#include<bits/stdc++.h>
using namespace std;
int n, m, c1, c2;
int a[501][501];
int b[501];
int vis[502];
vector<int>sp;
vector<int>sk;
int minx = 9999999;
void dfs(int s, int e, int len,int team) {
if (s == e) {
sp.push_back(len);
sk.push_back(team);
if (len < minx) {
minx = len;
}
return;
}
for (int i = 0; i < n; i++)
{
if (vis[i] == 1||s==i||a[s][i]==0)continue;
vis[i] = 1;
dfs(i, e, len + a[s][i],team+b[i]);
vis[i] = 0;
}
}
int main() {
cin >> n >> m >> c1 >> c2;
for (int i = 0; i < n; i++)
{
cin >> b[i];
}
while (m--)
{
int x, y, z;
cin >> x >> y >> z;
a[x][y] = a[y][x] = z;
}
dfs(c1, c2, 0,b[c1]);
int cd = -1;
int cnt = 0;
for (int i = 0; i < sp.size(); i++)
{
if (sp[i] == minx) {
cnt++;
if (sk[i] > cd) {
cd = sk[i];
}
}
}
cout << cnt << " " << cd;
}
无奈只有22分:
后面参考别人的思路再优化了下求结果的代码:
#include<bits/stdc++.h>
using namespace std;
int n, m, c1, c2;
int a[501][501];
int b[501];
int vis[502];
int pcnt = 0;
int minx = 9999999;
int num = 0;
void dfs(int s, int e, int len,int team) {
if (s == e) {
if (len < minx) {
pcnt = 1;
minx = len;
num = team;
}
else if (len == minx) {
pcnt++;
if (team > num) {
num = team;
}
}
else
return;
}
for (int i = 0; i < n; i++)
{
if (vis[i] == 1||s==i||a[s][i]==0)continue;
vis[i] = 1;
dfs(i, e, len + a[s][i],team+b[i]);
vis[i] = 0;
}
}
int main() {
cin >> n >> m >> c1 >> c2;
for (int i = 0; i < n; i++)
{
cin >> b[i];
}
while (m--)
{
int x, y, z;
cin >> x >> y >> z;
a[x][y] = a[y][x] = z;
}
dfs(c1, c2, 0,b[c1]);
cout << pcnt << " " <<num;
}
全过!!!