HDOJ 1032 The 3n + 1 problem详解(附加需要注意的坑)

 

问题 1095: The 3n + 1 problem

时间限制: 1Sec 内存限制: 64MB 提交: 1891 解决: 536

题目描述

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22: 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1, 000, 000. For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.

输入

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

输出

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.

样例输入

1 10
100 200
201 210
900 1000

样例输出

1 10 20
100 200 125
201 210 89
900 1000 174

题目意思:

如果该整数n是偶数,则n=n/2,

.如果是奇数,则n=n*3+1;一直运算下去,直到n=1停止。

输入两个数,比如第一组数据 1 10,要求我们分开计算从1到10的每个整数(包括端点数),求出运算次数最多的数字所运算的次数并输出,注意多组数据。

思路分析:1:如果第一个数比第二个数大,则要交换一下。

2:计数是从1开始,要算上本身。

其他代码都好理解。附上代码及注释

#include <iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int m,n,sum,maxsum,t,i,j;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		printf("%d %d",m,n);//输出两个数,记得要空一行 
		maxsum=0;//运算最大次数 
		if(n<m)//小的数放前面 
		{t=m;
		m=n;
		n=t;
		}
		i=m;j=n;
		for(;i<=j;i++)
		{
			n=i;//用n=i,因为下面n的运算会变回1才会进入for循环,如果是i,则一直运行下去了
			sum=1;//注意这里不是0 
			while(1)
		{
			
			if(n==1) break;
		
				if(n%2==0)//偶数 
				{
					n=n/2;sum++;//运算次数+1 
				}
				
				else//奇数 
				{
					n=n*3+1;sum++;//运算次数+1 
				}
				
			
			if(maxsum<sum)
			maxsum=sum;
			
		}
		}
		
		printf(" %d\n",maxsum);
	}
	return 0;
}

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值