修路Making the Grade(动态规划+ 离散化)

A straight dirt road connects two fields on FJ’s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, … , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . … , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2 - B2| + … + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single integer elevation: Ai

Output

  • Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input
7
1
3
2
4
5
3
9

Sample Output
3
题意:给你一个序列,求最少的代价让其变成单调不递增序列或单调不递减序列。

看到这道题目应该会想到用dp处理,dp[i][max]表示处理到前i位的最大值位max,于是只要两个for就可以,i=1~n,j=1~max。
dp[i][j]=min(dp[i][1~j]) + abs(a[i]-j),然后再从dp[n][1~max]中找最小的。
这题数据有点大如果用max会TLE,所以要将数据离散化一下。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
const int N=2222;
int a[N],b[N],c[N],dp[N][N],n,m;
int main() {
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%d",&a[i]),b[i]=a[i];
	sort(a+1,a+1+n);
	for(int i=1;i<=n;i++)
		dp[1][i]=abs(b[1]-a[i]);
	for(int i=2;i<=n;i++)
	{
		int k=dp[i-1][1];
		for(int j=1;j<=n;j++){
			k=min(k,dp[i-1][j]);
			dp[i][j]=k+abs(a[j]-b[i]);
		}
	}
	int ans=dp[n][1];
	for(int i=1;i<=n;i++){
		ans=min(ans,dp[n][i]);
	}
	printf("%d\n",ans);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值