poj3666 Making the Grade(dp)

Making the Grade

Description
A straight dirt road connects two fields on FJ’s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, … , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . … , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2 - B2| + … + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input
* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output
* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input
7
1
3
2
4
5
3
9

Sample Output
3

题意:给定长度为N的序列A,构造一个长度为N的非严格单调的序列B,使得
∑abs(Ai-Bi)最小。

分析:通过观察可以发现,序列B中的每个数一定在数列A中出现过,那么我们可以对A排序,设f[i][j]为把B的第i位变成A中第j大的数的最小代价,容易得到状态转移方程为
f[i][j]=min(f[i][j],f[i][k]+abs(b[i]-a[j])),其中1<=k<=j,但是这样时间复杂度为O(n^3),显然TLE,但是容易发现决策集合只增不减,记录最小值即可O(1)转移。

代码

#include <cstdio>
#include <algorithm>
#include <string>
#define inf 1e9
#define N 2005
using namespace std;

int a[N],b[N],f[N][N],n;

int main()
{
    scanf("%d", &n);
    memset(f, 127, sizeof(f));
    for (int i = 1; i <= n; i++)
    {
        scanf("%d", &a[i]);
        b[i] = a[i];
        f[0][i] = 0;
    }
    sort(a + 1, a + n + 1);
    for (int i = 1; i <= n; i++)
    {
        int minf = inf;
        for (int j = 1; j <= n; j++)
        {
            minf = min(minf, f[i - 1][j]);
            f[i][j] = min(minf + abs(a[j] - b[i]), f[i][j]);
        }
    }
    int ans = inf;
    for (int i = 1; i <= n; i++)
        ans = min(ans, f[n][i]);
    printf("%d", ans);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值