MPLS实验

拓扑

 

 

配置IP地址及环回

R1

<Huawei>sys
[Huawei]sysname r1
[r1]int l0
[r1-LoopBack0]ip add 192.168.1.1 24
[r1-LoopBack0]int g0/0/0
[r1-GigabitEthernet0/0/0]ip add 192.168.2.1 24

R2

<Huawei>sys
[Huawei]sysname r2
[r2]int l0
[r2-LoopBack0]ip add 2.2.2.2 24
[r2-LoopBack0]int g0/0/0
[r2-GigabitEthernet0/0/0]ip add 23.1.1.1 24

R3

<Huawei>sys
[Huawei]sysname r3
[r3]int l0
[r3-LoopBack0]ip add 3.3.3.3 24
[r3-LoopBack0]int g0/0/1
[r3-GigabitEthernet0/0/1]ip add 23.1.1.2 24
[r3-GigabitEthernet0/0/1]int g0/0/0
[r3-GigabitEthernet0/0/0]ip add 34.1.1.1 24

R4

<Huawei>sys
[Huawei]sysname r4
[r4]int l0
[r4-LoopBack0]ip add 4.4.4.4 24
[r4-LoopBack0]int g0/0/1
[r4-GigabitEthernet0/0/1]ip add 34.1.1.2 24
[r4-GigabitEthernet0/0/1]

R5

<Huawei>sys
[Huawei]sysname r5
[r5]int l0
[r5-LoopBack0]ip add 192.168.4.1 24
[r5-LoopBack0]int g0/0/0
[r5-GigabitEthernet0/0/0]ip add 192.168.3.2 24

R6

<Huawei>sys
[Huawei]sysname r6
[r6]int l0
[r6-LoopBack0]ip add 192.168.1.1 24
[r6-LoopBack0]int g0/0/0
[r6-GigabitEthernet0/0/0]ip add 192.168.2.1 24

R7

<Huawei>sys
[Huawei]sysname r7
[r7]int l0
[r7-LoopBack0]ip add 192.168.4.2 24
[r7-LoopBack0]int g0/0/0
[r7-GigabitEthernet0/0/0]ip add 192.168.3.2 24
[r7-GigabitEthernet0/0/0]int g0/0/1
[r7-GigabitEthernet0/0/1]ip add 47.1.1.2 24

配置OSPF

R2

[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
[r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0

R3

[r3]ospf 1 router-id 3.3.3.3
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0 
[r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0


R4

[r4]ospf 1 router-id 4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0

开启MPLS协议

R2

[r2]mpls lsr-id 2.2.2.2
[r2]mpls
[r2-mpls]mpls ldp
[r2-mpls-ldp]int g0/0/0
[r2-GigabitEthernet0/0/0]mpls ldp

R3

[r3]mpls lsr-id 3.3.3.3
[r3]mpls
[r3-mpls]mpls ldp
[r3-mpls-ldp]int g0/0/1
[r3-GigabitEthernet0/0/1]mpls ldp
[r3-GigabitEthernet0/0/1]int g0/0/0
[r3-GigabitEthernet0/0/0]mpls ldp

R4

[r4]mpls lsr-id 4.4.4.4
[r4]mpls
[r4-mpls]mpls ldp
[r4-mpls-ldp]int g0/0/1
[r4-GigabitEthernet0/0/1]mpls ldp

配置VPN空间,RD值和RT值

R2

[r2]ip vpn-instance a1
[r2-vpn-instance-a1]ipv4-family 
[r2-vpn-instance-a1-af-ipv4]route-distinguisher 1:1
[r2-vpn-instance-a1-af-ipv4]vpn-target 1:1

[r2]int g0/0/1
[r2-GigabitEthernet0/0/1]ip binding vpn-instance a1
[r2-GigabitEthernet0/0/1]ip add 192.168.2.2 24

[r2]ip vpn-instance b1
[r2-vpn-instance-b1]ipv4-family 
[r2-vpn-instance-b1-af-ipv4]route-distinguisher 2:2
[r2-vpn-instance-b1-af-ipv4]vpn-target 2:2

[r2]int g0/0/2
[r2-GigabitEthernet0/0/2]ip binding vpn-instance b1
[r2-GigabitEthernet0/0/2]ip add 192.168.2.2 24

[r4]ip vpn-instance a1
[r4-vpn-instance-a1]ipv4
[r4-vpn-instance-a1-af-ipv4]route-distinguisher 1:1
[r4-vpn-instance-a1-af-ipv4]vpn-target 1:1

[r4]int g0/0/0
[r4-GigabitEthernet0/0/0]ip binding vpn-instance a1
[r4-GigabitEthernet0/0/0]ip add 192.168.3.1 24

[r4]ip vpn-instance b1
[r4-vpn-instance-b1]ipv4-family 
[r4-vpn-instance-b1-af-ipv4]route-distinguisher 2:2
[r4-vpn-instance-b1-af-ipv4]vpn-target 2:2

[r4]int g0/0/2
[r4-GigabitEthernet0/0/2]ip binding vpn-instance b1
[r4-GigabitEthernet0/0/2]ip add 192.168.3.1 24

建立BGP邻居

R2

[r2]bgp 1
[r2-bgp]router-id 2.2.2.2
[r2-bgp]peer 4.4.4.4 as-number 1
[r2-bgp]peer 4.4.4.4 connect-interface LoopBack 0
[r2-bgp]ipv4-family vpnv4
[r2-bgp-af-vpnv4]peer 4.4.4.4 enable 

[r4]bgp 1
[r4-bgp]router-id 4.4.4.4
[r4-bgp]peer 2.2.2.2 as-number 1
[r4-bgp]peer 2.2.2.2 connect-interface LoopBack 0
[r4-bgp]ipv4-family vpnv4 
[r4-bgp-af-vpnv4]peer 2.2.2.2 enable 

建立静态连接

R1

[r1]ip route-static 192.168.3.0 24 192.168.2.2
[r1]ip route-static 192.168.4.0 24 192.168.2.2

R2

[r2]ip route-static vpn-instance a1 192.168.1.0 24 192.168.2.1
[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance a1 
[r2-bgp-a1]import-route direct 
[r2-bgp-a1]import-route static 

R4

[r4]ip route-static vpn-instance a1 192.168.4.0 24 192.168.3.2
[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance a1
[r4-bgp-a1]import-route direct 
[r4-bgp-a1]import-route static 

建立动态连接

R6

[r6]rip 1
[r6-rip-1]version 2
[r6-rip-1]network 192.168.1.0
[r6-rip-1]network 192.168.2.0

R2

[r2]rip 1 vpn-instance b1 
[r2-rip-1]version 2
[r2-rip-1]network 192.168.2.0

R7

 [r7]ospf 1 router-id 7.7.7.7
[r7-ospf-1]area 0
[r7-ospf-1-area-0.0.0.0]network 192.168.3.2 0.0.0.0
[r7-ospf-1-area-0.0.0.0]network 192.168.4.2 0.0.0.0

R4

[r4]ospf 2 vpn-instance b1
[r4-ospf-2]area 0
[r4-ospf-2-area-0.0.0.0]network 192.168.3.1 0.0.0.0

双向重发布

R2

[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance b1
[r2-bgp-b1]import-route rip 1
[r2-bgp-b1]q
[r2-bgp]q
[r2]rip 1 vpn-instance b1 
[r2-rip-1]import-route bgp

R4

[r4]ospf 2 vpn-instance b1
[r4-ospf-2]import-route bgp
[r4-ospf-2]q
[r4]bgp 1
[r4-bgp]ipv4    
[r4-bgp]ipv4-family vpn-instance b1
[r4-bgp-b1]import-route ospf 2

R2

[r2]ip route-static 0.0.0.0 0 23.1.1.2

R3

[r3]ip route-static 0.0.0.0 0 34.1.1.2

R7

[r7]acl 2000
[r7-acl-basic-2000]rule permit source any
[r7-acl-basic-2000]q
[r7]int g0/0/1
[r7-GigabitEthernet0/0/1]nat outbound 2000
[r7]ip route-static 0.0.0.0 0 47.1.1.1

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值