离散化(保序 / 非保序)

目录

概念

可能出现的问题

分类

1.保序

 离散化模板( https://www.acwing.com/blog/content/277/)

 例题:区间和

思路

代码

2.不保序


概念

        给定一系列要为坐标的值,可能很大,1 到 10e9  ,总不能开一个10e9的数组吧,就要涉及到离散化,将10e5个数(大小在10e9之内)映射到1~10e5,这个映射的过程就叫离散化。

可能出现的问题

        1.有重复元素,需要去重。

        2.如何算出a[ i ] 离散后的值。

分类

1.保序

排序判重+二分

 离散化模板( https://www.acwing.com/blog/content/277/

vector<int> alls; // 存储所有待离散化的值
sort(alls.begin(), alls.end()); // 将所有值排序
alls.erase(unique(alls.begin(), alls.end()), alls.end());   // 去掉重复元素

// 二分求出x对应的离散化的值
int find(int x) // 找到第一个大于等于x的位置
{
    int l = 0, r = alls.size() - 1;
    while (l < r)
    {
        int mid = l + r >> 1;
        if (alls[mid] >= x) r = mid;
        else l = mid + 1;
    }
    return r + 1; // 映射到1, 2, ...n  不加1,从0开始映射
}

 例题:区间和

假定有一个无限长的数轴,数轴上每个坐标上的数都是 0。现在,我们首先进行 n次操作,每次操作将某一位置 x 上的数加 c。接下来,进行 m次询问,每个询问包含两个整数 l 和 r,你需要求出在区间 [l,r]之间的所有数的和。

输入格式

第一行包含两个整数 n和 m。接下来 n行,每行包含两个整数 x 和 c。再接下来 m行,每行包含两个整数 l 和 r。

输出格式

共 m行,每行输出一个询问中所求的区间内数字和。

数据范围

−10e9 ≤ x ≤ 10e9,
1≤n,m≤10e5,
−10e9 ≤ l ≤ r ≤ 10e9,
−10000 ≤ c ≤ 10000

输入样例:

3 3
1 2
3 6
7 5
1 3
4 6
7 8

输出样例:

8
0
5

思路

        下标范围很大,但我们只用到n+m个(3*10e5);

        由前缀和思想,我们可以很快求出某一区间的值,要用前缀和,那么离散化后的数组下标要从1开始。所以二分返回结果要加1.

        要在某一个下标加上c的话,就算出它离散后的下标,并在那个位置加c;

        比如要求L,R之间的数,我们算出离散化的坐标LK,RK后,求LK,RK之间的和就可以了。

代码

#include <bits/stdc++.h>
#include <algorithm>
using namespace std;

const int N = 300010;
int n, m;
int a[N];//要存的数
int s[N];//前缀和

vector<int> alls;//存所有要离散化的值
typedef pair<int, int> PII;
vector<PII> add, query;
int find(int x) {
	int l = 0, r = alls.size() - 1;
	while (l < r) {
		int mid = l + r >> 1;
		if (alls[mid] >= x)r = mid;
		else l = mid + 1;
	}
	return r + 1;
}

int main() {
	//将所有数读进来,所有用到的下标离散化
	cin >> n >> m;
	for (int i = 0; i < n; i++) {
		int x, c;
		cin >> x >> c;
		add.push_back({ x, c });

		alls.push_back(x);
	}
	for (int i = 0; i < m; i++) {
		int l, r;
		cin >> l >> r;
		query.push_back({ l,r });

		alls.push_back(l);
		alls.push_back(r);
	}
	//放好以后开始去重
	sort(alls.begin(), alls.end());
	alls.erase(unique(alls.begin(), alls.end()), alls.end());

	for (auto item : add) {
		int x = find(item.first);
		a[x] += item.second;
	}
	//预处理前缀和;
	for (int i = 1; i <= alls.size(); i++) s[i] = s[i - 1] + a[i];
	//处理询问
	for (auto item : query) {
		int l = find(item.first), r = find(item.second);
		cout << s[r] - s[l - 1] << endl;
	}
	return 0;

}

2.不保序

 map或者hash表

https://blog.csdn.net/qq_59183443/article/details/127520112?csdn_share_tail=%7B%22type%22%3A%22blog%22%2C%22rType%22%3A%22article%22%2C%22rId%22%3A%22127520112%22%2C%22source%22%3A%22qq_59183443%22%7D

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星河边采花

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值