玩转二叉树 分数 25

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

思路:

根据二叉树前序和中序建树,这个题的镜像就是层序遍历的时候,先处理右节点即可。

代码:

#include <bits/stdc++.h>
using namespace std;
typedef pair<int, int> PII;
const int N = 510;
int n, m;
int in[35],pre[35];

 typedef struct Tree {
    int e;
    Tree *lchild, *rchild;
}*pT;

pT BuildTree(int root, int l, int r) {
    if (l > r)return NULL;
    pT t = (pT)malloc(sizeof(struct Tree));
    t->e = pre[root];
    int i = l;
    for (; i < r; i++)if (pre[root] == in[i])break;
    t->lchild = BuildTree(root + 1, l, i - 1);
    t->rchild = BuildTree(root + 1 + i - l, i + 1, r);
    return t;
}

void Ceng(pT t) {
    queue<pT> q;
    bool fg = true;
    if (!t)return;
    q.push(t);
    while (q.size()) {
        pT s = q.front();
        q.pop();
        if (fg) {
            cout << s->e;
            fg = false;
        }
        else cout << " " << s->e;
        if (s->rchild != NULL)q.push(s->rchild);
        if (s->lchild != NULL)q.push(s->lchild);
    }
}

int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)cin >> in[i];
    for (int i = 0; i < n; i++)cin >> pre[i];

    pT t = BuildTree(0, 0, n - 1);
    if (t == NULL)cout << "Y";
    Ceng(t);
    return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星河边采花

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值