7-5 树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

 

输入后序,输入中序,在后序序列中确定当前根结点,
并在中序中确定当前根结点所在的位置的下标,之后
递归的建立左子树和右子树。

层序遍历一定要有队列,队列里面放的还是指针类型!
#include<cstdio>
#include<iostream>
#include<queue>
using namespace std;
const int maxn=10010;

int n,k=0;
int layer[maxn],in[maxn],post[maxn];

struct node{
	
	int data;
	node* lchild;
	node* rchild;
};

node* create(int inL,int inR,int postL,int postR){
	
	if(postL>postR){
		
		return NULL;
	}
	
	node* root=new node;
	root->data=post[postR];
	
	int k;
	for(int i=0;i<n;i++){
		
		if(in[i]==post[postR]){
			
			k=i;
			break;
		}
		
	}
	
	int numLeft=k-inL;
	
	root->lchild=create(inL,k-1,postL,postL+numLeft-1);
	root->rchild=create(k+1,inR,postL+numLeft,postR-1);	
	
	return root;
}

void bfs(node* root){
	
	queue<node*> q;
	
	q.push(root);
	
	while(!q.empty()){
		
		node* top=q.front();
		q.pop();
		
		layer[k++]=top->data;
		
		if(top->lchild!=NULL) q.push(top->lchild);
		if(top->rchild!=NULL) q.push(top->rchild);
		
	}
	
}

int main(){
 	
	cin>>n;
	
	for(int i=0;i<n;i++){
		
		cin>>post[i];
	}
	
	for(int i=0;i<n;i++){
		
		cin>>in[i];
	}
	
	node* root=create(0,n-1,0,n-1);
	
	bfs(root);
	
	for(int i=0;i<n;i++){
		
		if(i) cout<<" ";
	   
	   cout<<layer[i];
	}
	
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值