1.题目
题目链接
题目背景
Bessie 处于半梦半醒的状态。过了一会儿,她意识到她在数数,不能入睡。
题目描述
Bessie的大脑反应灵敏,仿佛真实地看到了她数过的一个又一个数。她开始注意每一个数码(
0
…
9
0 \ldots 9
0…9):每一个数码在计数的过程中出现过多少次?
给出两个整数 M M M 和 N N N ( 1 ≤ M ≤ N ≤ 2 × 1 0 9 1 \leq M \leq N \leq 2 \times 10^9 1≤M≤N≤2×109 以及 N − M ≤ 5 × 1 0 5 N-M \leq 5 \times 10^5 N−M≤5×105),求每一个数码出现了多少次。
输入格式
第 1 1 1 行: 两个用空格分开的整数 M M M 和 N N N。
输出格式
第 1 1 1 行: 十个用空格分开的整数,分别表示数码 0 … 9 0 \ldots 9 0…9 在序列中出现的次数。
样例 #1
样例输入 #1
129 137
样例输出 #1
1 10 2 9 1 1 1 1 0 1
2.分析
思路1:转换为字符串,依次统计出现的次数
思路2:巧妙利用 / % 运算,取出每位数字,统计
3.代码
1.思路1(TLE ~ . ~)
考虑先转换为字符串,读入每个数字,而后依次排序,双指针计数(hhh~)
#include <iostream>
using namespace std;
#include <sstream> //int->string
#include <algorithm> //sort
int ans[10];
int main()
{
int bn, ed;
cin >> bn >> ed;
string res;
for (int i = bn; i <= ed; i++)
{
stringstream ss;
ss << i;
res += ss.str();
}
sort(res.begin(), res.end()); //排序
//双指针计数
for (int i = 0; i < res.size(); i++)
{
int j = i;
while (j < res.size() && res[j] == res[i]) j++;
ans[res[i]-'0'] = j - i; //res[i]-'0'表示代表的数字,j-i表示数量
i = j-1; //后移(注意i之后要++,所以等于j-1)
}
//输出
for (auto x : ans)
cout << x << ' ';
return 0;
}
2.思路1(将 1. 开吸氧优化可通过,不过还是不建议 )
如图:
3.思路1(优化)
可以直接在转换为字符串后,计数,省去排序和后续计数的时间浪费
#include <iostream>
using namespace std;
#include <sstream> //int->string
int ans[10];
int main()
{
int bn, ed;
cin >> bn >> ed;
string res;
for (int i = bn; i <= ed; i++)
{
res = to_string(i);
for (int j = 0; j < res.size(); j++)
ans[res[j] - '0']++;
}
for (auto x : ans)
cout << x << ' ';
return 0;
}
4.思路2
#include <iostream>
using namespace std;
int a[10];
int main()
{
int bg, ed;
cin >> bg >> ed;
for (int i = bg; i <= ed; i++)
{
int t = i;
while (t)
{
a[t % 10]++; //计数
t /= 10;
}
}
for (auto x : a)
cout << x << ' ';
return 0;
}
4.总结
思路2是较为优秀的解法~
5.更新日志
2022.6.12 整理上传
欢迎交流、讨论、指正~
不正确、不理解之处欢迎评论留言~