zcmu 1308: Permutation

1308: Permutation

Time Limit: 1 Sec  Memory Limit: 128 MB  Special Judge
Submit: 20  Solved: 12
[Submit][Status][Web Board]

Description

A permutation p is an ordered group of numbers p1,   p2,   ...,   pn, consisting of n distinct positive integers, each is no more than n. We'll define number n as the length of permutation p1,   p2,   ...,   pn.

 

Simon has a positive integer n and a non-negative integer k, such that 2k ≤ n. Help him find permutation a of length 2n, such that it meets this equation: .

Input

The first line contains two integers n and k (1 ≤ n ≤ 50000, 0 ≤ 2k ≤ n).

Output

Print 2n integers a1, a2, ..., a2n — the required permutation a. It is guaranteed that the solution exists. If there are multiple solutions, you can print any of them.

Sample Input

1 0

2 1

4 0

Sample Output

1 2

3 2 1 4

2 7 4 6 1 3 5 8

HINT

Record |x| represents the absolute value of number x.

In the first sample |1 - 2| - |1 - 2| = 0.

In the second sample |3 - 2| + |1 - 4| - |3 - 2 + 1 - 4| = 1 + 3 - 2 = 2.

In the third sample |2 - 7| + |4 - 6| + |1 - 3| + |5 - 8| - |2 - 7 + 4 - 6 + 1 - 3 + 5 - 8| = 12 - 12 = 0.

 

函数前一半把这个排列p两个数分为一组,用每组后面的数减去前面的数,再取他们的绝对值加起来,后一半把这个排列p两个数分为一组,用每组后面的数减去前面的数,把他们加起来再取绝对值。

构造一个升序序列,可以摘掉绝对值。此时k=0;

开始交换每组前后两个数,前一半值+1,后一半值+1,因为最后=2*k,只需交换k次。

构造一个上升序列1~2n,每次交换k+1到前面,输出。

#include<bits/stdc++.h>
#define ll long long
#define ve vector
#define mp map
#define NO cout<<"NO"<<endl;
#define YES cout<<"YES"<<endl;
#define pre(i,a,b) for(int i=a;i<=b;++i)
#define rep(i,b,a) for(int i=b;i>=a;--i)
#define mem(a,b) memset(a,b,sizeof(a))
#define st string
#define N 100005
#define Pi acos(-1.0) 
using namespace std;
const int maxn=1e6+5;
const ll mod =1e15;
const int dx[]={-1,0,1,0};
const int dy[]={0,1,0,-1};
//set<ll> s;
ve<ll> v;
priority_queue<ll, ve<ll>, greater<ll> >q;


int main(){
    int n,k;
    while(cin>>n>>k){
	n*=2;
	printf("%d ",k+1);
	pre(i,1,n) 
	   if(i!=k+1)printf("%d ",i);
	cout<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值