1998: Execution of Paladin
Time Limit: 2 Sec Memory Limit: 64 MB
Submit: 31 Solved: 24
[Submit][Status][Web Board]Description
Murloc is a powerful race in Hearthstone. In the set League of Explorers, a new Paladin ability card called Anyfin Can Happen is released with the ability to summon 7 Murlocs that died this game. If there aren’t enough dead Murlocs, it may summon less than 7 Murlocs.
There are many different minions in Murloc race, here are four of them:
Coldlight Oracle: 3 MANA, 2 ATTACK, 2 HP. Battlecry: Each player draws 2 cards.
Murloc Warleader: 3 MANA, 3 ATTACK, 3 HP. ALL other Murlocs have +2/+1.
Bluegill Warrior: 2 MANA, 2 ATTACK, 3 HP. Charge.
Old Murk-Eye: 4 MANA, 2 ATTACK, 3 HP. Charge. Has +1 Attack for each other Murloc on the Battlefield.
Here are some explanations:
MANA: The cost of summon the minion. Minions summoned by ability cards cost no mana besides the cost of the ability cards. Every player has 10 MANAs at most.
ATTACK: How many damage can the minion make once.
HP: How many attacks can the minion or heroes take.
Battlecry: An ability where a particular effect activates when the card with the Battlecry is played directly from the hand. The minions summoned by ability won’t activate their Battlecry.
Charge: Minions cannot attack at once when they are summoned unless they have Charge description. They will have to wait until next turn.
Battlefield: The battlefield (or game board) is where the action takes place, representing the board on which each game is played out.
+2/+1: +2 ATTACK and +1 HP.
Now, it is your turn. You have 10 MANAs and only one card: Anyfin Can Happen. There are nothing on the Battlefield, which means your minions can directly attack enemy hero. You can remember the list of dead Murlocs. You know how many HP the enemy hero remains. Will you win this game through this only card you have?
Input
Multiple test cases. The first line contains an integer T (T<= 22000), indicating the number of test case.
The first line of each test contains two integers, n (the number of dead Murlocs, 0 <= n <= 7) and h (the HP of enemy hero, 0 < h <= 30).
Then n lines follows, each line contains a string, indicates the name of dead Murloc. The string will only be “Coldlight Oracle”, “Murloc Warleader”, “Bluegill Warrior” or “Old Murk-Eye”.
Output
One line per case. If you can win the game in this turn, output “Mrghllghghllghg!”(Without quotes). Otherwise, output “Tell you a joke, the execution of Paladin.” You will win the game if you attack enemy hero with your minions and make his/her HP less or equal than 0.
Sample Input
3 3 1 Coldlight Oracle Coldlight Oracle Murloc Warleader 3 8 Old Murk-Eye Old Murk-Eye Coldlight Oracle 7 30 Old Murk-Eye Bluegill Warrior Bluegill Warrior Murloc Warleader Murloc Warleader Coldlight Oracle Coldlight Oracle
Sample Output
Tell you a joke, the execution of Paladin. Mrghllghghllghg! Tell you a joke, the execution of Paladin.
HINT
In the first test case, none of the Murlocs can attack.
In the second test case, every Old Murk-Eye has +2 ATTACK because there is another Old Murk-Eye and a Coldlight Oracle. So the total damage is 8.
In the last test case, Old Murk-Eye has 12 ATTACK (2 basic ATTACK, 6 other Murlocs and 2 Murloc Warleader), two Bluegill Warriors has 6 ATTACK(2 basic ATTACK, and 2 Murloc Warleader) each. So the total damage is 24.
Mrghllghghllghg!
玩过炉石就会写。
寒光智者:3费,2攻,2血,战吼:双方玩家各抽2张牌。
鱼人领军:3费,3攻,3血,其他鱼人获得+2/+1。
蓝腮战士:2费,2攻,3血,冲锋。
老瞎眼:4费,2攻,3血,冲锋。战场上每有1个其他鱼人就会使其获得+1攻击。
冲锋走脸不多解释。
伤害=老瞎眼攻击+蓝鳃战士攻击+(n-1)*老瞎眼的个数+鱼人领军增益攻击力。
#include<bits/stdc++.h>
#define ll long long
#define ve vector
#define mp map
#define NO cout<<"NO"<<endl;
#define YES cout<<"YES"<<endl;
#define pre(i,a,b) for(int i=a;i<=b;i++)
#define rep(i,b,a) for(int i=b;i>=a;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define st string
#define N 10005
using namespace std;
const int maxn=1e6+5;
const ll mod =1e15;
const int dx[]={-1,0,1,0};
const int dy[]={0,1,0,-1};
//set<ll> s;
ve<ll> v;
priority_queue<ll, ve<ll>, greater<ll> >q;
int a[maxn];
char s[105];
int main()
{
int t,n,m;
cin>>t;
while(t--){
cin>>n>>m;
getchar();
int OME=0,BW=0,ML=0,ans=0;
pre(i,0,n-1){
gets(s);
if(s[0]=='B')BW++;
else if(s[0]=='M')ML++;
else if(s[0]=='O')OME++;
}
ans=(n-1)*OME+2*(BW+OME)+2*ML*(OME+BW);
if(ans>=m)
cout<<"Mrghllghghllghg!"<<endl;
else
cout<<"Tell you a joke, the execution of Paladin."<<endl;
}
return 0;
}