ZOJ 1093 Monkey and Banana【排序 + DP】

题面

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input Specification
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output Specification
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

大意

给定若干种带有长、宽、高属性的长方体,问最高的积木搭多高。对于两个相邻的长方体,上面的底面宽高要严格小于下面的。

思路

排序 + DP。 把一个长方体的所有状态拆解,底面按长、宽递增。搭当前积木时,遍历之前搭过的所有小积木堆,找一个最高的叠上来。

状态转移方程: f[i] = max(f[j]) + h[i];
f[j] 表示用前j个长方体所能搭的最高积木。。

代码

#include <iostream>
#include <algorithm>
using namespace std;
const int N = 200;
struct Box{
	int x,y,z;
}box[N];
bool cmp(Box a, Box b){	// 小到大 
	if(a.x != b.x) return a.x < b.x; 
	if(a.y == b.y)
		return a.z < b.z;
	return a.y < b.y;
} 
int f[N];
void solve(int n, int tm){
	sort(box, box + n,cmp);
	for(int i = 0; i < n; i ++)	//basecase
		f[i] = box[i].z;
	for(int i = 0; i < n; i ++){
		for(int j = i-1; j >= 0; j --) {
			if(box[j].x < box[i].x && box[j].y < box[i].y) {
				f[i] = max(f[i], f[j] + box[i].z);
			}
		}
	}
	int mx = 0;
	for(int i = 0; i < n; i ++)
		mx = max(f[i], mx);
	cout << "Case "<< tm << ": maximum height = " << mx << endl;
}  
int main(){
	int n,a,b,c,tm=1;
	while(cin >> n,n){
		int id = 0;
		for(int i = 0; i < n; i ++){
			cin >> a >> b >> c;
			box[id++] = {a,b,c};
			box[id++] = {a,c,b};
			box[id++] = {c,b,a};
			box[id++] = {b,a,c};
			box[id++] = {c,a,b};
			box[id++] = {b,c,a};
		}
		solve(6*n, tm++);
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值