ZOJ 1093 Monkey and Banana(dp)

Monkey and Banana

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input Specification

The input file will contain one or more test cases. The first line of each test case contains an integer  n ,
representing the number of different blocks in the following data set. The maximum value for  n  is 30.
Each of the next  n  lines contains three integers representing the values  xi yi  and  zi .
Input is terminated by a value of zero (0) for  n .

Output Specification

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case  case : maximum height =  height "

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

Source:  University of Ulm Local Contest 1996


大致题意为:n种不同的砖块其长宽高(x,y,z),砖块能够翻转且取之不尽,问能搭多高,搭时满足要放的那块砖,其底面两条边小于下面那块砖的两条边。

思路:由于砖块可以翻转,相当于有6*n种不同的砖块,本题核心要明确一个观点:每种砖块最多放一个(呃。。。好好想想)。明确这个观点就可以进行下面了。

实现:既然每种砖块只可以放一块,计算以每种砖块为结尾的最大高度,再从中选择最大的。有点儿LIS的意思,不过LIS应用的前提为:有一个明确的前进方向。我们可以把砖块按x降序排序,构成一个前进方向。


AC代码:

#include <bits/stdc++.h>
using namespace std; 

struct block
{
	int x, y, z;
}box[200];

void oriente(int k, int x, int y, int z) {
	box[k].x = x;
	box[k].y = y;
	box[k].z = z;
}

bool cmp(block a,block b)
{
	return a.x>b.x;
}

int main ()
{
	int i,j;
	int n;
	int x,y,z;
	int dp[200];
	int Case=1;
	while(scanf("%d", &n) && n)
	{
		int number = 0;
		for(j=0; j<n; j++)
		{  
			scanf("%d%d%d", &x, &y, &z);
			oriente(number++, x, y, z);
			oriente(number++, x, z, y);
			oriente(number++, y, z, x);
			oriente(number++, y, x, z);
			oriente(number++, z, x, y);
			oriente(number++, z, y, x);
		}
		n *= 6;
		sort(box,box+n,cmp);
		memset(dp,0,sizeof(dp));
		int ans = 0;
		for(i=0; i<n; i++)//LIS 
		{
			dp[i]=box[i].z;
			for(j=0; j<i; j++)
				if(box[i].x<box[j].x && box[i].y<box[j].y)
					dp[i]=max(dp[i],dp[j]+box[i].z);
			ans=max(ans,dp[i]);
		}
		printf("Case %d: maximum height = %d\n", Case++, ans);
	}
	return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值