HDU 4310 Hero

Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 
Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 
Output
Output one line for each test, indicates the minimum HP loss.
 
Sample Input
 
  
1 10 2 2 100 1 1 100
 
Sample Output
 
  
20 201

题意:给定n个敌方英雄给出其攻击力和血量,你拥有无限的血量,敌方每次给你造成的伤害为敌方现存英雄伤害的总和,问消灭所有敌方英雄所花费的最小代价是多少

思路:计算出每个敌方英雄攻击力与血量的比值,比值越高的代表在相应的血量下造成的损害越多,因此要先消灭比值高的;于是我们将敌方英雄按比值排序即可

AC代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int N=25;

int n;
struct Hero
{
	int dps,hp;
	double d;
	bool operator<(const Hero&t)const
	{
		return d>t.d;
	}
}h[N];

int main()
{
	while(cin>>n)
	{
		int sum=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&h[i].dps,&h[i].hp);
			h[i].d=1.0*h[i].dps/h[i].hp;
			sum+=h[i].dps;
		}
		sort(h,h+n);
		int res=0;
		for(int i=0;i<n;i++)
		{
			res+=sum*h[i].hp;
			sum-=h[i].dps;
		}
		cout<<res<<endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Double.Qing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值