HDU 6276 Easy h-index

Problem Description

比赛题目:
http://acm.hdu.edu.cn/downloads/2018ccpc_hn.pdf

The h-index of an author is the largest h where he has at least h papers with citations not less than h.

Bobo has published many papers.
Given a0,a1,a2,…,an which means Bobo has published ai papers with citations exactly i, find the h-index of Bobo.
 

 

Input

The input consists of several test cases and is terminated by end-of-file.

The first line of each test case contains an integer n.
The second line contains (n+1) integers a0,a1,…,an.

 

Output

For each test case, print an integer which denotes the result.

## Constraint

* 1≤n≤2⋅105
* 0≤ai≤109
* The sum of n does not exceed 250,000.

 

Sample Input

 
 

1 1 2 2 1 2 3 3 0 0 0 0

 

Sample Output

 
 

1 2 0

思路:由于应用次数是递增的,于是我们可以从后向前遍历,每次将答案加上a[i]如果答案大于等于i就跳出循环并将i输出;

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int N=200010;

int a[N];

int main()
{
	int n;
	while(cin>>n)
	{
		for(int i=0;i<=n;i++)
			scanf("%d",&a[i]);
		int res=0;
		for(int i=n;i>=0;i--)
		{
			res+=a[i];
			if(res>=i)
			{
				res=i;
				break;
			}
		}
		printf("%d\n",res);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Double.Qing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值