PAT甲级 树 DFS

1021 Deepest Root

分数 25

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

代码长度限制

16 KB

时间限制

2000 ms

内存限制

64 MB

解法:

两步深搜

第一步:判断有没有其他连通子图

第二步:从叶子节dfs找最长深度,因为既然是树(N个节点N-1条边肯定无环),终点和起点肯定是叶子节点

坑点:n==1也算

代码:

#include<bits/stdc++.h>
using namespace std;
//就是找每个节点的最大深度,dfs;
int n;
vector<vector<int>> graph;
map<int,vector<int>,greater<int>> ans;
vector<int> visit;
int dangqian;

void dfs(int i){
    if(visit[i]) return;
    visit[i] = 1;
    for(auto o:graph[i]){
        dfs(o);
    }
}

void dfs2(int i,int ceng){
    if(visit[i]) return;
    visit[i] = 1;
    ceng++;
    dangqian = max(dangqian,ceng);
    for(auto o:graph[i]){
        dfs2(o,ceng);
    }
}

int main(){
    cin>>n;
    int a,b;
    graph.resize(n+1);
    visit.resize(n+1,0);
    //坑点n==1
    if(n==1) {
        cout<<1;
        return 0;
    }
    
    for(int i=0;i<n-1;i++){
        cin>>a>>b;
        graph[a].push_back(b);
        graph[b].push_back(a);
    }

    int count = 0;
    //连通分类的个数
    for(int i=1;i<=n;i++){
        if(!visit[i]){
            count++;
            dfs(i);
        }
    }
    
    if(count!=1){
        cout<<"Error: "<<count<<" components";
        return 0;
    }else{
        for(int i=1;i<=n;i++){
            if(graph[i].size()==1) {
                visit.assign(n+1,0);
                dangqian=0;
                dfs2(i,0);
                ans[dangqian].push_back(i);
            }
        }
        for(auto &m:ans){
            sort(m.second.begin(),m.second.end());
            for(auto l:m.second){
                cout<<l<<endl;
            }
            break;
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值