PAT甲级1081 最大公因数

1081 Rational Sum

分数 20

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
long long gcb(long long a,long long b){
    return b?gcb(b,a%b):a;
}
long long beishu(long long a,long long b){
    long long x=gcb(a,b);
    return a*(b/x);
}

long long a[101],b[101];
vector<long long> sig(101,1);
int main(){
    long long A=0,B;
    int n;
    cin>>n;
    char c;
    for(int i=0;i<n;i++){
        cin>>a[i]>>c>>b[i];
        if(a[i]<0){
            sig[i]=-1;
            a[i] = abs(a[i]);
        }
    }
    
    B=b[0];
    for(int i=0;i<n;i++){
        B=beishu(B,b[i]);
    }
    
    for(int i=0;i<n;i++){
        A+=a[i]*sig[i]*(B/b[i]);
        
    }
    
    long long k=gcb(A,B);
    if(A<0){
        cout<<"-";
        A=abs(A);
    }
    A=A/k;
    B=B/k;
    
    if(A==0){
        cout<<0;
        return 0;
    }
    if(A>B){
        cout<<A/B;
    }
    if(A>B&&A%B){
        cout<<" ";
    }
    if(A%B){
        cout<<A%B<<"/"<<B;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值