手机尾号(%d的深度使用)

问题:

样例输入

2

13512345678

13787600321

样例输出

645678

600321

代码(1):

#include<stdio.h>
#include<string.h>
int main()

{
    int a,b,i,n;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%6d%5d",&a,&b);
        printf("6%d\n",b);
    }
    return 0;
}

代码(2)

#include<stdio.h>

#include<string.h>

int main()

{

    int n,a,b,c,d,e,f;

    while(~scanf("%d",&n))

    while(n--)

    {

        scanf("%6d%1d%1d%1d%1d%1d",&a,&b,&c,&d,&e,&f);

        printf("6%1d%1d%1d%1d%1d\n",b,c,d,e,f);

    }

     return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值