北林oj数据结构210

基于顺序存储结构的图书信息表的最佳位置图书的查找

描述

定义一个包含图书信息(书号、书名、价格)的顺序表,读入相应的图书数据来完成图书信息表的创建,然后根据指定的最佳位置的序号,查找该位置上的图书,输出相应图书的信息。

输入

总计n+m+2行。首先输入n+1行,其中,第一行是图书数目n,后n行是n本图书的信息(书号、书名、价格),每本图书信息占一行,书号、书名、价格用空格分隔,价格之后没有空格。其中书号和书名为字符串类型,价格为浮点数类型。然后输入m+1行,其中,第一行是一个整数m,代表查找m次,后m行每行内容为一个整数,代表待查找的图书的位置序号。

输出

输出m行 若查找成功: 输出内容为第i次查询的指定位置上的一本图书的信息(书号、书名、价格),书号、书名、价格用空格分隔,其中价格输出保留两位小数。 若查找失败: 只输出以下提示:抱歉,最佳位置上的图书不存在!

输入样例 1 

8
9787302257646 Data-Structure 35.00
9787302164340 Operating-System 50.00
9787302219972 Software-Engineer 32.00
9787302203513 Database-Principles 36.00
9787810827430 Discrete-Mathematics 36.00
9787302257800 Data-Structure 62.00
9787811234923 Compiler-Principles 62.00
9787822234110 The-C-Programming-Language 38.00
2
2
0

输出样例 1

9787302164340 Operating-System 50.00
Sorry,the book on the best position doesn't exist!

#include<iostream>
#include<string>
#include<iomanip>
#define Maxsize 100
using namespace std;

struct Book {
	string no;
	string name;
	double price;
};

struct sqlist {
	Book elem[Maxsize];
	int length;
};

void init(sqlist& L) {
	L.length = 0;
}

void input(sqlist& L) {
	int n;
	cin >> n;
	while (n != 0) {
		n--;
		cin >> L.elem[L.length].no >> L.elem[L.length].name >> L.elem[L.length].price;
		L.length++;
	}	
	return ;	
}





void output(sqlist& L) {
	int cishu;
	cin >> cishu;
	int xuhao, s[Maxsize];
	for (int i = 0; i < cishu; i++) {
		cin >> xuhao;
		s[i] = xuhao;
	}

	for (int i = 0; i < cishu; i++) {
		if (s[i] > 0 && s[i] <= L.length) {
			cout << L.elem[s[i]-1].no << " " << L.elem[s[i]-1].name << " " << fixed << setprecision(2) << L.elem[s[i]-1].price << endl;
		}
		else
		{
			cout << "Sorry,the book on the best position doesn't exist!" << endl;
		}
	}
	
	

			
}


int main() {
	sqlist l;
	init(l);
	input(l);
	output(l);
	return 0;

}

  • 5
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值