【最长最短单词】

题目描述:

输入1行句子(不多于200个单词,每个单长度不超过100),只包含字母、空格和逗号。单词由至少一个连续的字母构成,空格和逗号都是单词间的间隔。

试输出第1个最长的单词和第1个最短单词。

输入描述:

一行句子。

输出描述:

两行输出:第1行,第一个最长的单词;第2行,第一个最短的单词。

样例输入:
I am studying Programming language C in Peking University

样例输出:
Programming
I

代码如下:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<istream>
#include<iomanip>
#include<ostream>
#include<list>
#include<vector>
#include<set>
#include<map>
#include<fstream>
#include<stack>
#include<ctime>
#include<deque>
#include<queue>
#include <sstream>

#pragma warning (disable:4996)

using namespace std;

int main()
{
    string sentence;
    getline(cin, sentence);

    string longest_word, shortest_word;
    int longest_length = 0, shortest_length = 101;

    string word;
    for (int i = 0; i < sentence.length(); i++) {
        if (sentence[i] == ',' || sentence[i] == ' ') {
            if (word.length() > 0) {
                if (word.length() > longest_length) {
                    longest_length = word.length();
                    longest_word = word;
                }
                if (word.length() < shortest_length) {
                    shortest_length = word.length();
                    shortest_word = word;
                }
                word.clear();
            }
        }
        else {
            word += sentence[i];
        }
    }

    if (word.length() > 0) {
        if (word.length() > longest_length) {
            longest_length = word.length();
            longest_word = word;
        }
        if (word.length() < shortest_length) {
            shortest_length = word.length();
            shortest_word = word;
        }
    }

    cout << longest_word << endl;
    cout << shortest_word << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

武帝为此

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值