6-3 时间类 - 3. 时、分、秒的设置和读取

请为时间类添加时、分、秒数的设置和读取功能。

#include <iostream>
#include <iomanip>
using namespace std;

/* 你提交的代码将被嵌在这里 */

int main()
{
    MYTIME a;
    int h, m, s;
    cin >> h >> m >> s;
    a.Hour(h);
    a.Minute(m);
    a.Second(s);
    a.Output();
    cout << endl;
    a.Input();
    h = a.Hour();
    m = a.Minute();
    s = a.Second();
    cout << h << ' ' << m << ' ' << s << endl;
    return 0;
}

输入样例

8 30 45
21:42:59

输出样例

08:30:45
21 42 59

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

答案

class MYTIME {
private:
    int hour;
    int minute;
    int second;
public:
    void Output()
    {
        cout << setfill('0') << setw(2) << this->hour << ':' <<
            setfill('0') << setw(2) << this->minute << ':' <<
            setfill('0') << setw(2) << this->second;
    }
    void Input()
    {
        char sign = ':';
        cin >> this->hour >> sign >> this->minute >> sign >> this->second;
    }
    void Hour(int h) { hour = h; }
    void Minute(int m) { minute = m; }
    void Second(int s) { second = s; }
    int Hour() { return this->hour; }
    int Minute() { return this->minute; }
    int Second() { return this->second; }

};

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

拾-光

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值