6-6 时间类 - 6. 与总秒数间的换算

请为时间类添加时间与总秒数的换算功能。

#include <iostream>
#include <iomanip>
using namespace std;

/* 你提交的代码将被嵌在这里 */

int main()
{
    MYTIME a;
    int s;
    cin >> s;
    a.TotalSecond(s);
    a.Output();
    cout << endl;
    a.Input();
    s = a.TotalSecond();
    cout << s << endl;
    return 0;
}

输入样例1

1
8:30:45

输出样例1

Create 00:00:00
00:00:01
30645
Destroy 08:30:45

输入样例2

-172801
19:15:28

输出样例2

Create 00:00:00
23:59:59
69328
Destroy 19:15:28


注:本题中的总秒数是指当天的总秒数。若给出的值不在 [0, 86399] 内,则需要进行适当的转换。例如:86401 等价于1,-1 等价于 86399。

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

答案

class MYTIME {
private:
    int second=0;
    int hour=0;
    int minute=0;
public:
    void Input()
    {
        char sign = ':';
        cin >> hour >> sign >> minute >> sign >> second;
    }
    MYTIME()
    {
        cout << "Create" << ' ' << setfill('0') << setw(2) << hour << ':'
            << setfill('0') << setw(2) << minute << ':'
            << setfill('0') << setw(2) << second << endl;
    }
    void TotalSecond(int s)
    {
        if(s >= 0 && s <= 86399)
        {
        hour = s / 3600;//8
        minute = (s - 3600 * hour) / 60;
        second = (s - 3600 * hour) - 60 * minute;
        }

        if(s >= 86400) 
        {
        s %= 86400;
        hour = s / 3600;//8
        minute = (s - 3600 * hour) / 60;
        second = (s - 3600 * hour) - 60 * minute;
        }

        if(s <= -1)
        {
        while(s <= -1)
        s += 86400; 
        hour = s / 3600;//8
        minute = (s - 3600 * hour) / 60;
        second = (s - 3600 * hour) - 60 * minute;
        }

    }
    void Output()
    {
        cout <<  setfill('0') << setw(2) << hour << ':'
            << setfill('0') << setw(2) << minute << ':'
            << setfill('0') << setw(2) << second;
    }
    ~MYTIME()
    {
        cout << "Destroy" << ' ' << setfill('0') << setw(2) << hour << ':'
            << setfill('0') << setw(2) << minute << ':'
            << setfill('0') << setw(2) << second;
    }
    int TotalSecond()
    {
        return (hour * 3600 + minute * 60 + second);
    }
};

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

拾-光

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值