定义接口或类 Shape,定义求周长的方法length()。
定义如下类,实现接口Shape或父类Shape的方法。
(1)三角形类Triangle (2)长方形类Rectangle (3)圆形类Circle等。
定义测试类ShapeTest,用Shape接口(或类)定义变量shape,用其指向不同类形的对象,输出各种图形的周长。并为其他的Shape接口实现类提供良好的扩展性。
提示: 计算圆周长时PI取3.14。
输入格式:
输入多组数值型数据(double);
一行中若有1个数,表示圆的半径;
一行中若有2个数(中间用空格间隔),表示长方形的长度、宽度。
一行中若有3个数(中间用空格间隔),表示三角形的三边的长度。(需要判断三个边长是否能构成三角形)
若输入数据中有0或负数,则不表示任何图形,周长为0。
输出格式:
行数与输入相对应,数值为根据每行输入数据求得的图形的周长。
输入样例:
在这里给出一组输入。例如:
1
2 3
4 5 6
2
-2
-2 -3
输出样例:
在这里给出相应的输出。例如:
6.28
10.00
15.00
12.56
0.00
0.00
import java.util.Scanner;
import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Main {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
Shape shape;
while(sc.hasNext()) {
String content=sc.nextLine();
String Reg="-?\\d+\\.\\d+|-?\\d+";
Pattern pattern=Pattern.compile(Reg);
Matcher matcher=pattern.matcher(content);
int i=0;
String []nums=new String[3];
while(matcher.find()){
++i;
nums[i-1]=matcher.group(0);
}
if (i==2) {//长方形
double a=Double.parseDouble(nums[0]);
double b=Double.parseDouble(nums[1]);
shape = new Rectangle(a,b);
System.out.printf("%.2f", shape.length());
System.out.println();
}
else if (i==3) {//三角形
double a=Double.parseDouble(nums[0]);
double b=Double.parseDouble(nums[1]);
double c=Double.parseDouble(nums[2]);
shape = new Triangle(a,b,c);
System.out.printf("%.2f",shape.length());
System.out.println();
}
else if(i==1){//圆形
shape = new Circle(Double.parseDouble(nums[0]));
System.out.printf("%.2f",shape.length());
System.out.println();
}
}
sc.close();
}
}
interface Shape {
double length();
}
class Triangle implements Shape{//三角形
private double a,b,c;
public Triangle(double a, double b, double c) {
this.a=a;
this.b=b;
this.c=c;
}
public double length() {
if(a<=0||b<=0||c<=0) {
return 0;
}
else if(a+b<=c||a+c<=b||b+c<=a) {
return 0;
}
else {
return a+b+c;
}
}
}
class Rectangle implements Shape{//长方形
private double a,b;
public Rectangle(double a,double b){
this.a=a;
this.b=b;
}
public double length(){
if(a<=0||b<=0) {
return 0;
}
else {
return 2*(a+b);
}
}
}
class Circle implements Shape{//圆形
private double radius;
public Circle (double radius){
this.radius=radius;
}
public double length() {
if(radius<=0){
return 0;
}
else {
return 2*3.14*radius;
}
}
}