(Java版)1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

计算a+b,并以标准格式输出总和——也就是说,数字必须用逗号分成三组(除非数字少于四位)。

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10的6次方≤a,b≤10的6次方. The numbers are separated by a space.

每个输入文件包含一个测试用例。每种情况都包含一对整数a和b,其中−10的6次方≤a,b≤10的6次方

。这些数字用空格隔开。

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

对于每个测试用例,您应该在一行中输出a和b的总和。总和必须以标准格式书写。

Sample Input:

-1000000 9

Sample Output:

-999,991

import java.util.*;
class Main{
    public static void main(String[]args)
    {
        Scanner sc = new Scanner(System.in);
        int n1 = sc.nextInt();
        int n2 = sc.nextInt();
        int res = n1 + n2;
        boolean flag = false;//如果是负数,则为true
        if(res < 0)
        {
            flag = true;
            res = - res;
        }
        String s = String.valueOf(res);//将数字转化为字符串处理
        Stack<String> stack = new Stack<>();//利用栈后进先出的特性
        int n = s.length();
        while(true)
        {
            if(n - 3 >= 0)
            {
                stack.push(s.substring(n-3,n));//从后往前处理,压进栈
                n -= 3;
                if(n == 0)//防止n = 0时,截取到"",这也会压进栈内
                {
                    break;
                }
            }
            else 
            {
                stack.push(s.substring(0,n));
                break;
            }
        }
        if(flag == true)
        {
            System.out.print("-");
        }
        while(!stack.isEmpty())
        {
            if(stack.size()!= 1)
            {
                System.out.print(stack.pop() + ",");
            }
            else 
            {
                System.out.print(stack.pop());
            }
        }
    }
}


​

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值