7-3 jmu-Java-06异常-04-自定义异常(综合)

题目描述:

定义IllegalScoreException异常类,代表分数相加后超出合理范围的异常。该异常是checked exception,即希望该异常一定要被捕获处理。

定义IllegalNameException异常类,代表名字设置不合理的异常。该异常是unchecked exception

定义Student类。

属性:

private String name;
private int score;

方法:

toString          //自动生成
setter/getter     //自动生成
改造setName       //如果姓名首字母为数字则抛出IllegalNameException
public int addScore(int score)  //如果加分后分数<0 或>100,则抛出IllegalScoreException,加分不成功。

main方法

  1. 输入new则新建学生对象。然后输入一行学生数据,格式为姓名 年龄,接着调用setName,addScore。否则跳出循环。
  2. setName不成功则抛出异常,并打印异常信息,然后继续下一行的处理。
  3. addScore不成功则抛出异常,并打印异常信息,然后继续下一行的处理。如果2、3都成功,则打印学生信息(toString)
  4. 如果在解析学生数据行的时候发生其他异常,则打印异常信息,然后继续下一行的处理。
  5. Scanner也是一种资源,希望程序中不管有没有抛出异常,都要关闭。关闭后,使用System.out.println("scanner closed")打印关闭信息

**注意:**使用System.out.println(e);打印异常信息,e为所产生的异常。

输入样例:

new
zhang 10
new
wang 101
new
wang30
new
3a 100
new
wang 50
other

输出样例:

Student [name=zhang, score=10]
IllegalScoreException: score out of range, score=101
java.util.NoSuchElementException
IllegalNameException: the first char of name must not be digit, name=3a
Student [name=wang, score=50]
scanner closed

答案:

import java.util.Scanner;

public class Main{
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        while(true){
            String str = sc.next();
            if("new".equals(str)){
                try {
                    String name = sc.next();
                    int score = sc.nextInt();
                    Stu stu = new Stu(name,score);
                    System.out.println(stu);
                }catch (illegalNameException | illegalScoreException e){
                    System.out.println(e);
                }catch (Exception e){
                    System.out.println("java.util.NoSuchElementException");
                }
            }else{
                break;
            }
        }
        System.out.println("scanner closed");
    }
}
class illegalScoreException extends RuntimeException{
    String score;
    public illegalScoreException() {
    }

public illegalScoreException(String message) {
    this.score = message;
}

@Override
public String toString() {
    return "IllegalScoreException: score out of range, score="+score;
}

}
class illegalNameException extends RuntimeException{
    String name;
    public illegalNameException() {
    }

public illegalNameException(String message) {
    this.name = message;
}

@Override
public String toString() {
    return "IllegalNameException: the first char of name must not be digit, name="+name;
}

}
class Stu{
    private String name;
    private int score;

public String getName() {
    return name;
}

public Stu() {
}

public Stu(String name, int score) {
    if(name.charAt(0)>='0'&&name.charAt(0)<='9'){
        throw new illegalNameException(name);
    }
    if(score<0||score>100){
        throw new illegalScoreException(score+"");
    }
    this.name = name;
    this.score = score;
}

@Override
public String toString() {
    return "Student [name="+name+", score="+score+"]";
}

public void setName(String name) {
    this.name = name;
}

public int getScore() {
    return score;
}

public void setScore(int score) {
    this.score = score;
}

}

解析:

像那种需要指定异常输出格式的,重写自定义异常里的toString方法就好了。

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值