7-1 jmu-Java-06异常-01-常见异常

题目描述:

自行编码产生常见异常。

main方法

  1. 事先定义好一个大小为5的数组。
  2. 根据屏幕输入产生相应异常。

**提示:**可以使用System.out.println(e)打印异常对象的信息,其中e为捕获到的异常对象。

输入说明:

  1. arr 代表产生访问数组是产生的异常。然后输入下标,如果抛出ArrayIndexOutOfBoundsException异常则显示,如果不抛出异常则不显示。
  2. null,产生NullPointerException
  3. cast,尝试将String对象强制转化为Integer对象,产生ClassCastException
  4. num,然后输入字符,转化为Integer,如果抛出NumberFormatException异常则显示。
  5. 其他,结束程序。

输入样例:

arr 4
null
cast
num 8 
arr 7 
num a 
other 

输出样例:

java.lang.NullPointerException java.lang.ClassCastException: class java.lang.String cannot be cast to class java.lang.Integer (java.lang.String and java.lang.Integer are in module java.base of loader 'bootstrap') java.lang.ArrayIndexOutOfBoundsException: Index 7 out of bounds for length 5 java.lang.NumberFormatException: For input string: "a" 

答案:

import java.util.*;
class Main{
    public static void main(String[] args){
        int[] arr = new int[5];
        Scanner sc = new Scanner(System.in);
        while(true) {
            String choice = sc.next();
            try {
                if ("arr".equals(choice)) {
                    int index = sc.nextInt();
                    int num = arr[index];
                } else if("null".equals(choice)){
                        throw new NullPointerException();
                }else if("cast".equals(choice)) {
                    Object obj = new String("dsf");
                    Integer num = (Integer)obj;
                }else if("num".equals(choice)){
                    String str = sc.next();
                    Integer num = Integer.parseInt(str);
                }else{
                    break;
                }
            }catch (Exception e){
                System.out.println(e);
            }
        }
    }
}

解析:

这题有点意思,自己故意写报错还从来没试过( - v -)

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值