HCIP综合实验1

一.实验拓扑

二.实验要求

        1、R5为ISP,只能进行IP地址配置,其所有地址均配为公有Ip地址;

        2、  R1和R5间使用PPP的PAP认证,R5为主认证方;

                R2与R5之间使用PPP的CHAP认证,R5为主认证方;

                R3与R5之间使用HDLC封装;

        3、R2、R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE;

        4、整个私有网络基本RIP全网可达;

        5、所有PC设置私有IP为源IP,可以访问R5环回;

三.实验思路

        1.配置设备IP地址

        2.私网公网全网通

        3.配置pap,chap,HDLC封装

        4.配置MGRE,GRE

        5.配置RIP协议

        6.配置NAT,使得访问内网环回

四.实验步骤

1.ip地址的配置
//R1 IP地址配置
[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip ad 192.168.1.1 24
[R1]int s4/0/0
[R1-Serial4/0/0]ip ad 15.1.1.1 24
//R2 IP地址配置
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip ad 192.168.2.2 24
[R2]int s4/0/0
[R2-Serial4/0/0]ip ad 25.1.1.2 24
//R3 IP地址配置
[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip ad 192.168.3.3 24
[R3]int s4/0/0
[R3-Serial4/0/0]ip ad 35.1.1.3 24
//R4 IP地址配置
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip ad 45.1.1.4 24
[R4]int g0/0/1
[R4-GigabitEthernet0/0/1]ip ad 192.168.4.4 24
//R5 IP地址配置
[R5]int g 0/0/0
[R5-GigabitEthernet0/0/0]ip ad 45.1.1.5 24
[R5]int s4/0/1
[R5-Serial4/0/1]ip ad 15.1.1.5 24
[R5]int s4/0/0
[R5-Serial4/0/0]ip ad 35.1.1.5 24
[R5]int s3/0/1
[R5-Serial3/0/1]ip ad 25.1.1.5 24
[R5]int LoopBack 0
[R5-LoopBack0]ip ad 5.5.5.5 24
 2.路由表配置
[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R2]ip route-static 0.0.0.0 0 25.1.1.5
[R3]ip route-static 0.0.0.0 0 35.1.1.5
[R4]ip route-static 0.0.0.0 0 45.1.1.5
 3.PAP的配置
//R5作为主验证方进行配置
[R5]aaa
[R5-aaa]local-user rjw password cipher 123456
Info: Add a new user.	
[R5-aaa]local-user rjw service-type ppp
[R5-aaa]int s4/0/1
[R5-Serial4/0/1]ppp a	
[R5-Serial4/0/1]ppp authentication-mode pap
//R1作为被验证方
[R1]int s4/0/0
[R1-Serial4/0/0]ppp pap local-user rjw password c	
[R1-Serial4/0/0]ppp pap local-user rjw password cipher 123456
4.CHAP的配置
//R5作为验证方进行配置
[R5]aaa
[R5-aaa]loc	
[R5-aaa]local-user rrr password cipher 123456
Info: Add a new user.
[R5-aaa]local-user rrr service-type ppp
[R5-aaa]int s3/0/1
[R5-Serial3/0/1]ppp authentication-mode chap
//R2作为被验证方进行配置
[R2]int s4/0/0
[R2-Serial4/0/0]ppp chap user rrr	
[R2-Serial4/0/0]ppp chap password cipher 123456
5.配置HDLC
[R3]int s 4/0/0
[R3-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
[R5]int s4/0/0
[R5-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
6.MGRE
//R1为中心站点,搭建R2与R3MGRE环境
//R1
[R1]int Tunnel 0/0/0
[R1-Tunnel0/0/0]ip ad 20.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 15.1.1.1
Mar 30 2024 13:00:23-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R1-Tunnel0/0/0]	
[R1-Tunnel0/0/0]nhrp network-id 100
//R2
[R2]int Tunnel 0/0/0
[R2-Tunnel0/0/0]ip ad 20.1.1.2 24	
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp	
[R2-Tunnel0/0/0]source Serial 4/0/0
Mar 30 2024 13:04:03-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R2-Tunnel0/0/0]
[R2-Tunnel0/0/0]nhrp net	
[R2-Tunnel0/0/0]nhrp network-id 100
[R2-Tunnel0/0/0]nhrp entry 20.1.1.1 15.1.1.1 register 
//R3
[R3]int Tunnel 0/0/0
[R3-Tunnel0/0/0]ip ad 20.1.1.3 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source Serial 4/0/0
Mar 30 2024 13:08:09-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp entry 20.1.1.1 15.1.1.1 register
7.GRE
//搭建R1与R4之间点到点的GRE环境
//R1
[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]ip ad 10.1.1.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]destination 45.1.1.4
//R4
[R4]int Tunnel 0/0/1
[R4-Tunnel0/0/1]ip ad 10.1.1.4 24
[R4-Tunnel0/0/1]tunnel-protocol gre
[R4-Tunnel0/0/1]source 45.1.1.4
[R4-Tunnel0/0/1]destination 15.1.1.1
8.RIP配置
//R1 rip的配置
[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]undo summary 	
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 20.0.0.0
[R1-rip-1]network 10.0.0.0
[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]undo rip split-horizon
//R2 rip的配置
[R2]rip 1
[R2-rip-1]version 2
[R2-rip-1]undo summary
[R2-rip-1]network 192.168.2.0
[R2-rip-1]network 20.0.0.0
[R2-Tunnel0/0/1]undo rip split-horizon
//R3 rip的配置
[R3]rip 1
[R3-rip-1]version 2
[R3-rip-1]undo summary 
[R3-rip-1]network 192.168.3.0
[R3-rip-1]network 20.0.0.0
[R3-Tunnel0/0/1]undo rip split-horizon 
//R4 rip的配置
[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]undo summary 
[R4-rip-1]network 192.168.4.0	
[R4-rip-1]network 10.0.0.0
[R4-Tunnel0/0/1]undo rip split-horizon 
9.NAT配置
//R1
[R1]acl number 2000 
[R1-acl-basic-2000]rule 5 permit source 192.168.1.0 0.0.0.255
//配置下发
[R1-Serial4/0/0]nat outbound 2000
//R2
[R2]acl number 2000 
[R2-acl-basic-2000]rule 5 permit source 192.168.2.0 0.0.0.255
[R2-Serial4/0/0]nat outbound 2000
//R3
[R3]acl number 2000 
[R3-acl-basic-2000]rule 5 permit source 192.168.3.0 0.0.0.255
[R3-Serial4/0/0]nat outbound 2000
//R4
[R4]acl number 2000 
[R4-acl-basic-2000]rule 5 permit source 192.168.4.0 0.0.0.255
[R4-GigabitEthernet0/0/1]nat outbound 2000

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值