数据结构专题——栈的应用

问题 A: 简单计算器

时间限制: 1 Sec  内存限制: 32 MB
提交: 1627  解决: 659
[提交][状态][讨论版][命题人:外部导入]

题目描述

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出

12178.21
#include<cstdio>
#include<iostream>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
using namespace std;
const int maxn=100010;

struct node{//为了栈和队列能够同时存数与操作符 
	char op;
	double num;
	bool flag;
};

string str;
map<char,int> op;//设置运算符的优先级 
queue<node> q;
stack<node> s;

void change(){
	
	double num; 
	node t;
	
	for(int i=0;i<str.length();){
		if(str[i]>='0'&&str[i]<='9'){
			num=str[i++]-'0';
			while(i<str.length()&&str[i]>='0'&&str[i]<='9'){
				num=num*10+(str[i]-'0');
				i++;
			}
			t.flag=true;
			t.num=num;
			q.push(t);
		}
		else{
			t.flag=false;
			
			while(!s.empty()&&op[str[i]]<=op[s.top().op]){
				q.push(s.top());
				s.pop();
			}
			
			t.op=str[i];
			s.push(t);	
			
			i++;
		}
		
	}
	
	while(!s.empty()){
		q.push(s.top());
		s.pop();
	}
	
}
double cal(){
	
	node cur,t;
	double t1,t2,num;
	char op;
	
	while(!q.empty()){
		
	        cur=q.front();
		    q.pop();
		       
		if(cur.flag==true){
			s.push(cur);
		}
		else{
			op=cur.op;
			
			t2=s.top().num;//注意结构体与数 
			s.pop();
			t1=s.top().num;
			s.pop();
			
			switch(op){
				case '+':
					num=t1+t2;
					break;
				case '-':
					num=t1-t2;
					break;
				case '*':
					num=t1*t2;
					break;
				case '/':
					num=t1/t2;
					break;	
			}
			t.num=num;//最好在运算后再将结果赋给t  
			t.flag=true;
			s.push(t);
		}

	}

	return s.top().num; 
}

int main(){
	
	op['+']=op['-']=1;
	op['*']=op['/']=2; 
	
	while(getline(cin,str),str!="0"){//注意getline让str得到一行,遇到空格停
	 
		
		while(!s.empty()) s.pop();
		
		string::iterator it;
		for(it=str.begin();it!=str.end();it++)
		 if(*it==' ')  str.erase(it);
		 
		change();  
		
		printf("%.2f\n",cal());
	}
	
	
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值