杭电1010---Tempter of the Bone

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 83349    Accepted Submission(s): 22707

 Problem Description

The doggie found a bone in an ancient maze,which fascinated him a lot. However, when he picked it up, the maze began toshake, and the doggie could feel the ground sinking. He realized that the bonewas a trap, and he tried desperately to get out of this maze.

 The maze was a rectangle with sizes N by M.There was a door in the maze. At the beginning, the door was closed and itwould open at the T-th second for a short period of time (less than 1 second).Therefore the doggie had to arrive at the door on exactly the T-th second. Inevery second, he could move one block to one of the upper, lower, left andright neighboring blocks. Once he entered a block, the ground of this blockwould start to sink and disappear in the next second. He could not stay at oneblock for more than one second, nor could he move into a visited block. Can thepoor doggie survive? Please help him.

Input

The input consists of multiple test cases.The first line of each test case contains three integers N, M, and T (1 < N,M < 7; 0 < T < 50), which denote the sizes of the maze and the time atwhich the door will open, respectively. The next N lines give the maze layout,with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggiecannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

 The input is terminated with three 0's.This test case is not to be processed.

 Output

For each test case, print in one line"YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0

 Sample Output

NO

YES

分析:刚开始以为这是一道简单的BFS,就快写出来的代码,后来发现提交一直wrong。后来就跟学长讨论,发现这是一道规定路径,即规定的时间到达某一地。后来就写DFS的代码,写出来之后就是超时。一直超时,上网看了别人的代码,需要剪枝。如果开始的点为(0,0),需要到达的点为(2,2)。则从(0,0),到达(2,2).的距离为4;如果给的T是偶数就能到达,如果给的T是奇数,就不能达到。如果开始点为(0,0),需要到达的点为(1,2),则从(0.0)到达点(1,2)的步数为3,如果给的T是偶数,那么就不能到达,如果是奇数就能到达。所以奇偶剪枝就是始点到达终点的距离加上时间T,如果他们的和是奇数就直接输出NO

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int dx[]={1,0,0,-1};
int dy[]={0,1,-1,0};
int n,m,t;
int zx,zy,sx,sy;
int flag;
char mp[10][10];
int vis[10][10];
struct dot
{
    int x,y;
};
inline bool in(dot gx)
{
    if(gx.x>=0&&gx.x<n&&gx.y>=0&&gx.y<m)
    return true;
   return false;
}
void dfs(int x,int y,int time)
{
    dot next;
    if(flag)                               //找到后剪枝
        return ;
    if(time==t)
    {
       if(x==zx&&y==zy)
        {
            flag=1;
            return ;
        }
    }
    if(t<=time)
        return ;
    int tmp=fabs(zx-x)+fabs(zy-y);           //奇偶性剪枝
    if(tmp>t-time||(tmp+t-time)%2==1)
        return ;

     for(int i=0;i<4;i++)
     {
         int x1=x+dx[i];
         int y1=y+dy[i];
         next.x=x1;
         next.y=y1;
         if(in(next)&&mp[x1][y1]!='X'&&!vis[x1][y1])
         {
             vis[x1][y1]=1;
             dfs(x1,y1,time+1);
             vis[x1][y1]=0;
         }

     }
}
int main()
{
  while(cin>>n>>m>>t)
  {
      int count1=1;
      if(m==0&&n==0&&t==0)
        break;
      memset(vis,0,sizeof(vis));
      for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
           cin>>mp[i][j];
      for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
         {
             if(mp[i][j]=='S')
             {
                 sx=i;
                 sy=j;
             }
             if(mp[i][j]=='D')
             {
                 zx=i;
                 zy=j;
             }
             if(mp[i][j]=='.')                //记录可以走的路
             {
                 count1++;
             }
             if(mp[i][j]=='X')              //把墙标记为1
             {
                 vis[i][j]=1;
             }
         }
         flag=0;
         vis[sx][sy]=1;                  //它的位置很重要,一个细节把它放在dfs后面,错了很多次
         dfs(sx,sy,0);
         
         int dis=fabs(zx-sx)+fabs(zy-sy);
         if((dis+t)%2)                     //奇偶性剪枝
         {
             printf("NO\n"); 
             continue;
         }
         if(count1<t)               //如果可以走的路比规定的时间少,就输出NO
         {
              printf("NO\n");
             continue;
         }
         if(flag)
         {
             printf("YES\n");
         }
         else
         {
             printf("NO\n");
         }

  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值