FatMouse' Trade(贪心)-HDU

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 

Sample Output
13.333
31.500

题意+分析:本题就是老鼠用猫粮换取自己最喜爱的食物javaBean的一个过程。换取的最终结果是保证最后的JavaBean是最多的。所以在解这道题时候要想到按照每个仓库javaBean最大的比率排序才能保证最后的交换的javaBean是最大的。

那,就直接看代码吧:

#include<cstdio>
#include<algorithm>
using namespace std;

struct node
{
	double a;
	double b;
	double c;
}fj[1001];

int compare(node a,node b)
{
	return a.c > b.c;
}

int main()
{
	int i,m,n;
	double j,f,sum;
	while(scanf("%d%d",&m,&n), m!=-1 || n!=-1)
	{
		sum = 0;
		for(i = 0; i < n; i ++)
		{
			scanf("%lf%lf",&fj[i].a,&fj[i].b);
			fj[i].c = fj[i].a / fj[i].b;
		}
		sort(fj,fj+n,compare);
		for(i = 0; i < n; i ++)
		{
			if(m - fj[i].b > 0.001)
			{
				sum += fj[i].a;
				m -= fj[i].b;
			}
			else
			{
				sum += fj[i].c*m;
				break;
			}
		}
		printf("%.3f\n",sum);
	}
	return 0;
}

还有一个是我用C写的,就是比较的时候没有用sort

#include<stdio.h>
int main()
{
	int i,j,m,n;
	double t1,t2,t3,J[1001],F[1001],sum,a[1001];
	while(scanf("%d%d",&m,&n), m!=-1 || n!=-1)
	{
		sum = 0.0;
		for(i = 1; i <= n; i ++)
		{
			F[i] = 0;J[i] = 0;a[i] = 0;
		}
		for(i = 1; i <= n; i ++)
		{
			scanf("%lf%lf",&J[i],&F[i]);
			a[i] = J[i]/F[i];
		}
		for(i = 1; i < n; i ++)
			for(j = 1; j <= n-i; j ++)
				if(a[j] < a[j+1])
				{
					t1 = a[j];
					a[j] = a[j+1];
					a[j+1] = t1;
					t2 = F[j];
					F[j] = F[j+1];
					F[j+1] = t2;
					t3 = J[j];
					J[j] = J[j+1];
					J[j+1] = t3;
				}
		for(i = 1; i <= n; i ++)
		{
			if(F[i] < m)
			{
				sum += J[i];
				m -= F[i];
			}
			else if(F[i] == m)
			{
				sum += J[i];
				break;
			}
			else
			{
				sum += a[i]*m;
				break;
			}
		}
		printf("%.3f\n",sum);
	}
	return 0;
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值