a letter and a number
时间限制:3000 ms | 内存限制:65535 KB
难度:1
描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ...f(Z) = 26, f(z) = -26;
Give you a letter xand a number y , you should output the result of y+f(x).
输入
Onthe first line, contains a number T(0<T<=10000).then T lines follow, eachline is a case.each case contains a letter x and a number y(0<=y<1000).
输出
foreach case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
代码如下:
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main()
{
int n,y;
char x;
scanf("%d",&n);
getchar();
while(n--)
{
scanf("%c%d",&x,&y);
if(x < 'a') //代表都是大写字母
printf("%d\n",x-'A'+1+y);
else //剩下就是小写字母
printf("%d\n",'a'-x-1+y);
getchar();
}
}