HDU--1062--Text Reverse

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
Sample Output
hello world!
I'm from hdu.
I like acm.
//用C语言处理字符串问题,c++中取消的gets() 和strlen()两个函数 
#include<stdio.h>
#include<string.h>
char str[1010];
int main(){
	int t;
	scanf("%d",&t);
	getchar();//getchar()用于缓冲,不可小看他的作用 
	while(t--){
		gets(str);
		int len=strlen(str);
		int start=0;
		bool flag=0;
		for(int i=0;i<len;i++){
			if(str[i]==' '){
				if(flag)	
					printf(" ");
				for(int k=i-1;k>=start;k--)
					printf("%c",str[k]);
				start=i+1;
				flag=1;
			}
			if(i==len-1){
				printf(" ");
				for(int k=i;k>=start;k--)
					printf("%c",str[k]);
			}
		}
		puts("");
	}
}
/*Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca

Sample Output
hello world!
I'm from hdu.
I like acm.
*/

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值