Text Reverse
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25495 Accepted Submission(s): 9884
Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca
Sample Output
hello world!
I’m from hdu.
I like acm.
Hint
Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.
题意:输入一段话,翻转每个单词后输出,注意可能有多个空格,且输入的前几个字符可能就是空格。
思路:有用传统数组水的,有用栈的先进先出性水的,为了练习string,我是直接调用string
string用法http://blog.csdn.net/qq_32680617/article/details/51122395
代码
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<stack>
using namespace std;
int main()
{
int t,loc;
cin>>t;
getchar();//刚开始把回车读掉
string s1;
while (t--)
{
getline(cin,s1);
loc=0;//刚开的begin是0
while (s1.find(" ",loc)!=string::npos)//反转前n-1个单词,只要能找到空格在字符串中的位置,就进入循环
{
reverse( s1.begin()+loc , s1.begin()+s1.find(" ",loc) );//翻转单词
loc=s1.find(" ",loc)+1;//找到了则更新下一次要用的不然就死循环了
}
reverse( s1.begin()+s1.find_last_of(" ")+1 , s1.end() );//将最后一个反转
cout<<s1<<endl;
}
return 0;
}
附上用栈的代码(来自网络)
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<stack>
using namespace std;
int main()
{
int n;
char ch;
scanf("%d",&n);
getchar(); /*吸收回车符*/
while(n--)
{
stack<char> s; /*定义栈*/
while(true)
{
ch=getchar(); /*压栈时,一次压入一个字符*/
if(ch==' '||ch=='\n'||ch==EOF)
{
while(!s.empty())
{
printf("%c",s.top());
s.pop(); /*清除栈顶元素*/
}
if(ch=='\n'||ch==EOF)
break; /*绝对不能少,控制输出结束*/
printf(" ");
}
else
s.push(ch);
}
printf("\n");
}
return 0;
}