POJ3468 A simple problem with integers(区间更新)

A Simple Problem with Integers
Time Limit: 5000MSMemory Limit: 131072K
Total Submissions: 55949Accepted: 16877
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
wa了好多次,最后终于ac了
#include<stdio.h>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=111111;
__int64 sum[maxn<<2];                      //不定义__int64为必wa
__int64 vis[maxn<<2];
void pushup(int rt)
{
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
if(vis[rt])
{
vis[rt<<1]+=vis[rt];
vis[rt<<1|1]+=vis[rt];
sum[rt<<1]+=(m-(m>>1))*vis[rt];
sum[rt<<1|1]+=(m>>1)*vis[rt];
vis[rt]=0;                           //这里最后记得置为零
}
}
void build(int l,int r,int rt)
{
vis[rt]=0;
if(l==r)
{
scanf("%I64d",&sum[rt]);            //输入也要__int64
return;
}
     int m=(l+r)>>1;
build(lson);
build(rson);
pushup(rt);
}
void update(int L,int R,int add,int l,int r,int rt)
{
    if(L <=l&&R>=r)
    {
vis[rt]+=add;
sum[rt]+=add*(r-l+1);
return;
}
pushdown(rt,r-l+1);
int m=(l+r)>>1;
if(L <=m)
update(L,R,add,lson);
if(R>m)
update(L,R,add,rson);
pushup(rt);
}
__int64 getsum(int L,int R,int l,int r,int rt)
{
__int64 ret=0;                       //因为这里没有定义__int64错了好几次
if(L <=l&&R >=r)
{
return sum[rt];
}
pushdown(rt,r-l+1);                     //求和也要pushdown??反正我不明白为什么,以后再看
int m=(l+r)>>1;
if(L <=m)
ret+=getsum(L,R,lson); 
if(R >m)
ret+=getsum(L,R,rson);
   return ret;
}
int main()
{
int a,b,x,y,z,n,m;
char s[5];
scanf("%d%d",&n,&m);
build(1,n,1);
for(int i=0;i<m;i++)
   {
scanf("%s",s);
if(s[0]=='Q')
{
scanf("%d%d",&a,&b);
printf("%I64d\n",getsum(a,b,1,n,1));
}
if(s[0]=='C')
{
scanf("%d%d%d",&x,&y,&z);
update(x,y,z,1,n,1);
}
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值