HDU--1010--Tempter of the Bone

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

 

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES

思路:迷宫问题扩展,奇偶剪枝,在大佬博客上参考了一下,终于终于解决.....

AC代码:

#include <cstdio>
#include <iostream>
#include<cmath>
using namespace std;
char map[10][10];
int m,n,t,sa,sb,da,db,flag,sum;
int to[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
void dfs(int x,int y,int time){
	int k,p,q;
	if(x==da&&y==db&&time==t){
		flag=1;
		return;
	}
	k=(t-time)-(abs(da-x)+abs(db-y));
	if(k<0||k&1) return;
	for(int i=0;i<4;i++){
		p=x+to[i][0];
		q=y+to[i][1];
		if(p<0||p>=m||q<0||q>=n) continue;
		if(map[p][q]!='X'){
			map[p][q]='X';
			dfs(p,q,time+1);
			if(flag) return;
			map[p][q]='.';
		}
	}
	return ;
}
int main(){
	while(scanf("%d%d%d",&m,&n,&t)&&(m+n+t)!=0){
		sum=0;
		int i,j;
		for(i=0;i<m;i++){
			scanf("%s",map[i]);
		}
		for(i=0;i<m;i++){//记录初始位置与终点位置 
			for(j=0;j<n;j++){
				if(map[i][j]=='S'){
					sa=i;
					sb=j;
				}
				if(map[i][j]=='X'){
					sum++;
				}
				if(map[i][j]=='D'){
					da=i;
					db=j;
				}
			}
		}
		if(m*n-sum<=t)
			printf("NO\n");
		else{
			flag=0;
			map[sa][sb]='X';
			dfs(sa,sb,0);
			if(flag){
				printf("YES\n");
			}
			else{
				printf("NO\n");
			}
		}
	}
}

附上我自己起初写的代码,无论怎么更改都是wawawawawa....

看到底应该怎么解决???真的是提交了无数次了!!!

#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<map>
#include<cstdio>
using namespace std;
int n,m,t;
const int MAX=1000+10; 
char maze[MAX][MAX];
bool vis[MAX][MAX];//标记数组 
int dir[4][2]={{-1,0},{0,-1},{1,0},{0,1}};//方向数组 
bool dfs(int x, int y){
    if(maze[x][y]=='D'){//终点退出 
        return true;
    }
    vis[x][y]=1;
    maze[x][y]='q';//用m标记,之后统计TTTT 
    for(int i=0;i<4;i++){
        int tx=x+dir[i][0];
        int ty=y+dir[i][1];
        if(0<=tx&&tx<n&&0<=ty&&ty<m&&maze[tx][ty]!='X'&&!vis[tx][ty]){
            if(dfs(tx,ty)){
                return true;
            }
        }
    }
    vis[x][y]=0;
    maze[x][y]='.'; 
    return false;
}
int main(){
    while(scanf("%d%d%d",&n,&m,&t)&&(n+m+t)!=0){ 
    	memset(maze,0,sizeof(maze));
    	memset(vis,false,sizeof(vis));
	    for(int i=0;i<n;i++){
	        scanf("%s",maze[i]);
	    }
	    int x,y;//定义起点x,y; 
	    for(int i=0;i<n;i++){
	        for (int j=0;j<m;j++){
	            if (maze[i][j]=='S'){
	                x=i,y=j;//找起点
					break; 
	            }
	        }
	    }
	    int ans=0;
	    bool flag=dfs(x,y);
	    if(flag){
	        for(int i=0;i<n;i++)
	        	for(int j=0;j<m;j++)
	    			if(maze[i][j]=='q')
	    				ans++;
	    } 
	    if(ans==t)
	    	cout<<"YES"<<endl;
	    else
	    	cout<<"NO"<<endl;
	    
	} 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值