POJ--2549--折半枚举

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input
5
2 3 5 7 12
5
2 16 64 256 1024
0
Sample Output
12
no solution

思路:折半枚举即可;

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int MAX=1000+10;
const int inf=-600000000;
long long int n,a[MAX];
int main(){
	while(scanf("%lld",&n)!=EOF&&n){
		for(int i=0;i<n;i++)
			scanf("%lld",&a[i]);
		sort(a,a+n);//应该可以不用考虑
		n--;
		long long int ans=inf;
		for(int i=n;i>=0;i--){ 
			for(int j=n;j>=0;j--){
				if(i==j)	continue;
				long long int sum=a[i]-a[j];
				for(int c=0,d=j-1;c<d;){
					if(a[c]+a[d]==sum){ 
						ans=a[i];
						break;
					}else if(a[c]+a[d]>sum){ 
						d--;
					}else
						c++;
				}
				if(ans!=inf)	break; 
			}
			if(ans!=inf)	break;
		} 
		if(ans==inf)	printf("no solution\n");
		else	printf("%d\n",ans);
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值