D - How Many Answers Are Wrong

传送门:How Many Answers Are Wrong

TT and FF are … friends. Uh… very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

BoringBoringa very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
Output
A single line with a integer denotes how many answers are wrong.
Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1
Sample Output
1

题意:告诉你m个区间的权值,找出错误的区间的权值的数量。注意,在未找出明显错误权间权值前,都认为前面的到上一个错误区间之间的都是对的。
思路:是一道区间并查集的经典题目,第一次接触这种类型的题目,有点懵。看了一些人的博客才弄懂了。

首先sum数组是这道题的核心,你可以把它理解为该节点到它的祖宗节点的权值,如果把它理解为区间的话,就是左闭右闭的区间,区间的左端点是该节点,右端点为它的祖宗节点。
以下为示意图:
在这里插入图片描述
其中B是A的祖宗节点。

接下来回到题目本身,当两个节点的祖宗节点相同时,说明他们在一个区间里,我们假设b在下方,a在上方,那么就是判断sum[b]-sum[a]是否等于s了,不等于就ans++;
以下为示意图:
在这里插入图片描述
由于sum是左闭右闭的区间,所以a要减一,这样sum[b]-sum[a]就是[a,b]这个区间的权值了。

当两个节点的祖宗节点不同时,示意图如下:
在这里插入图片描述

我们先让pa成为pb的祖宗节点,由于sum[a],sum[b]都在find函数里求出来了,s已知,sum[pb]就可以求出来了,sum[pb]=s+sum[a]-sum[b];
具体见代码。
代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int N=2e5+5;
int f[N],sum[N];//f[i]表示i的父亲,sum[i]表示i这个点到f[i]这个点之间的和
int find(int x)
{
	if(x!=f[x])
	{
		int pre=f[x];
		f[x]=find(f[x]);//路径压缩,使所有的节点指向根节点,
		sum[x]+=sum[pre];//之所以在这里加就是等所有的部分都更新完后在这里就一次性更新就好了
	}
	return f[x];
}
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	
	memset(sum,0,sizeof(sum));
	int ans=0;
	for(int i=1;i<=n;i++)
	f[i]=i;
	while(m--)
	{
		int a,b,s;
		scanf("%d%d%d",&a,&b,&s);
		a--;
		int pa=find(a);
		int pb=find(b);
		if(pa==pb)
		{
			if(sum[b]-sum[a]!=s)
			ans++;
		}
		else{
			f[pb]=pa;
			sum[pb]=s+sum[a]-sum[b];
		}
	}
	printf("%d\n",ans);	
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是代码形式的电话线路图状态: ``` @startuml title Telephone State Diagram [*] --> Idle : Initial State Idle --> Dialing : Off Hook Event Dialing --> Connecting : Valid Number Event Dialing --> Disconnected : Invalid/Wrong Number Event Connecting --> TimeOut : Timeout Event Connecting --> Connected : Called Phone Answers Event Ringing --> Connected : Called Phone Answers Event Connected --> Idle : On Hook Event Connected --> Busy Tone : Line Busy Event Connected --> TimeOut : Timeout Event Connected --> Disconnected : Timeout Event Connected --> Ringing : Play Message Event @enduml ``` 解释一下: - 初始状态为空闲状态(`[*] --> Idle : Initial State`)。 - 当电话机摘机时,电话状态从空闲状态转入拨号状态(`Idle --> Dialing : Off Hook Event`)。 - 当拨号有效号码时,电话状态从拨号状态转入连接状态(`Dialing --> Connecting : Valid Number Event`)。 - 当拨号号码无效或错误时,电话状态从拨号状态转入未连接状态(`Dialing --> Disconnected : Invalid/Wrong Number Event`)。 - 当连接超时时,电话连接状态从连接状态转入超时状态(`Connecting --> TimeOut : Timeout Event`)。 - 当被拨打的电话接听时,电话连接状态从连接状态或响铃状态转入已连接状态(`Connecting --> Connected : Called Phone Answers Event` 或 `Ringing --> Connected : Called Phone Answers Event`)。 - 当已连接状态的电话机挂机时,电话状态从已连接状态转入空闲状态(`Connected --> Idle : On Hook Event`)。 - 当已连接状态的电话线路忙碌时,电话状态从已连接状态转入忙音状态(`Connected --> Busy Tone : Line Busy Event`)。 - 当已连接状态的电话连接超时时,电话状态从已连接状态转入未连接状态(`Connected --> TimeOut : Timeout Event`)。 - 当已连接状态的电话播放信息时,电话状态从已连接状态转入响铃状态(`Connected --> Ringing : Play Message Event`)。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值