POJ 1064 Cable master(二分求可行解)

题意:给若干条绳子,在保证绳子被裁出一定数量且长度相等的情况下,每条绳子最长是多少。

解题思路:二分枚举每条绳子的长度,查看是否能裁出题目要求的数量,若不能说明上界取大了, 压缩上界,若能,压缩 下界,看是否能够更优。

本题需要控制精度,每条绳子的长度需要保留两位小数,所以先对最终找到的答案向下取证,再*100 / 100。

问题描述

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

输入

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

输出

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

样例输入

4 11
8.02
7.43
4.57
5.39

样例输出

2.00

Memory: 808 KB Time: 110 MS
Language: G++ Result: Accepted

#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

/**************************************************************/
#define MAX_N 10005
#define eps 1e-8
const int INF = 0x3f3f3f3f;
double a[MAX_N];
int n, k;
bool f(double x)
{
    int num = 0;
    for(int i = 0 ; i < n ; i++)
    {
        num += (int)(a[i] / x);
    }
    return num >= k;
}

int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        for(int i = 0 ; i < n ; i++)
        {
            scanf("%lf", &a[i]);
        }
        double lb = 0, ub = INF;
        while(ub - lb > eps)
        {
            double m = (lb + ub) / 2;
            if(f(m)) lb = m;
            else ub = m;
        }
        printf("%.2f\n", floor(ub * 100) / 100);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值