POJ 2456 Aggressive cows (最大化最小值)

题意:一群好斗的奶牛,再能安排所有奶牛的情况下, 让最近的奶牛离得尽可能的远。

解题思路:输入进来的牛舍的距离是无序的,所以先排序,二分枚举可能的距离, 查看是否能把所有的奶牛全部安排开,若不能,压缩上界, 若能压缩下界找更优解。

问题描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

输入

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

输出

* Line 1: One integer: the largest minimum distance

样例输入

5 3
1
2
8
4
9

样例输出

3

提示

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.
Memory: 1092 KB Time: 32 MS
Language: G++ Result: Accepted

#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define FOR(i, s, t) for(int i = (s) ; i <= (t) ; ++i)
#define REP(i, n) for(int i = 0 ; i < (n) ; ++i)

int buf[10];
inline long long read()
{
    long long x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}

inline void writenum(int i)
{
    int p = 0;
    if(i == 0) p++;
    else while(i)
        {
            buf[p++] = i % 10;
            i /= 10;
        }
    for(int j = p - 1 ; j >= 0 ; --j) putchar('0' + buf[j]);
}
/**************************************************************/
#define MAX_N 100005
const int INF = 0x3f3f3f3f;
int a[MAX_N];
int n, c;

bool f(int x)
{
    int h = 0;
//    int l = h + 1;
    for(int i = 1 ; i < c ; i++)
    {
        int l = h + 1;
        while(l < n && a[l] - a[h] < x)
        {
            l++;
        }
        if(l == n) return false;
        h = l;
    }
    return true;
}

int main()
{

    while(~scanf("%d%d", &n, &c))
    {
        for(int i = 0 ; i < n ; i++)
        {
            a[i] = read();
        }
        sort(a, a + n);
        int lb = -1, ub = INF;
        while(ub - lb > 1)
        {
            int m = (ub + lb) / 2;
            if(f(m)) lb = m;
            else ub = m;
        }
        printf("%d\n", lb);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值