POJ 2976 Dropping tests(最大化平均值)

题意:给出n门课程,并给出每门课的所考的成绩和这门课的总成绩,可以去掉k门课, 求最大的平均分。

解题思路:平均分是sum(a[i]) / sum(b[i]),可行性函数判断的是, sum(a[i]) / sum(b[i]) >= x, 数学变换得sum(a[i] - x * b[i]) >= 0,所以每次进行可行性判断时先对a[i] - x * b[i]进行排序。


Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).



#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define FOR(i, s, t) for(int i = (s) ; i <= (t) ; ++i)
#define REP(i, n) for(int i = 0 ; i < (n) ; ++i)

int buf[10];
inline long long read()
{
    long long x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}

inline void writenum(int i)
{
    int p = 0;
    if(i == 0) p++;
    else while(i)
        {
            buf[p++] = i % 10;
            i /= 10;
        }
    for(int j = p - 1 ; j >= 0 ; --j) putchar('0' + buf[j]);
}
/**************************************************************/
#define MAX_N 1005
const int INF = 0x3f3f3f3f;
int a[MAX_N];
int b[MAX_N];
double c[MAX_N];
int n, k;

bool f(double x)
{
//    cout<<1<<endl;
    for(int i = 0 ; i < n ; i++)
    {
        c[i] = a[i] - x * b[i];
    }
    sort(c, c + n);
//    for(int i = 0 ; i < n ; i++)
//    {
//        cout<<c[i]<<" ";
//    }
//    cout<<endl;
    double sum = 0;
    for(int i = 0 ; i < n - k ; i++)
    {
        sum += c[n - i - 1];
//        cout<<sum<<endl;
    }
//    cout<<sum<<endl;
    return sum >= 0;
}

int main()
{
//    freopen("in.txt", "r", stdin);
//	freopen("out.txt", "w", stdout);
    while(scanf("%d%d", &n, &k) && (n || k))
    {
        for(int i = 0 ; i < n ; i++)
        {
            a[i] = read();
        }
        for(int i = 0 ; i < n ; i++)
        {
            b[i] = read();
        }
        double lb = 0, ub = 1;
        while(ub - lb > 1e-8)
        {
            double mid = (lb + ub) / 2;
            if(f(mid)) lb = mid;
            else ub = mid;
        }
        int ans = floor(ub * 100 + 0.5);
        printf("%d\n", ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值