UVA 1210 Sum of Consecutive Prime Numbers(素数打表)

9 篇文章 0 订阅

题意:给定一个整数n, 问有多少个若干个连续的素数的和为n。

解题思路:打出MAX_N以内的素数表, 枚举即可。


Some positive integers can be represented by a sum of one or more consecutive prime numbers. How
many such representations does a given positive integer have? For example, the integer 53 has two
representations 5+7+11+13+17 and 53. The integer 41 has three representations 2+3+5+7+11+13,
11 + 13 + 17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no
such representations. Note that summands must be consecutive prime numbers, so neither 7 + 13 nor
3 + 5 + 5 + 7 is a valid representation for the integer 20. Your mission is to write a program that reports
the number of representations for the given positive integer.
Input
The input is a sequence of positive integers each in a separate line. The integers are between 2 and
10000, inclusive. The end of the input is indicated by a zero.
Output
The output should be composed of lines each corresponding to an input line except the last zero. An
output line includes the number of representations for the input integer as the sum of one or more
consecutive prime numbers. No other characters should be inserted in the output.
Sample Input
2
3
17
41
20
666
12
53
0
Sample Output
1
1
2
3
0
0
1
2


#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define FOR(i, s, t) for(int i = (s) ; i <= (t) ; ++i)
#define REP(i, n) for(int i = 0 ; i < (n) ; ++i)

int buf[10];
inline long long read()
{
    long long x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}

inline void writenum(int i)
{
    int p = 0;
    if(i == 0) p++;
    else while(i)
        {
            buf[p++] = i % 10;
            i /= 10;
        }
    for(int j = p - 1 ; j >= 0 ; --j) putchar('0' + buf[j]);
}
/**************************************************************/
#define MAX_N 10010
const int INF = 0x3f3f3f3f;
int isprime[MAX_N];
int prime[MAX_N];
int cnt = 0;
void make_prime()
{
    cnt = 0;
    memset(isprime, 1, sizeof(isprime));
    isprime[1] = 0;
    for(long long i = 2 ; i < MAX_N ; i++)
    {
        if(isprime[i])
        {
            prime[cnt++] = i;
        }
        for(long long j = i * i ; j < MAX_N ; j += i)
        {
            isprime[j] = 0;
        }
    }
}

int main()
{
    make_prime();
    int n;
    while(~scanf("%d", &n) && n)
    {
        int ans = 0;
        int p1, p2;
        p1 = p2 = 0;
        int sum = 0;
        while(prime[p2] <= n && p1 <= p2)
        {
            sum = 0;
            for(int i = p1 ; i <= p2 ; i++)
            {
                sum += prime[i];
            }
            if(sum < n)
            {
                p2++;
            }
            else if(sum == n)
            {
                ans++;
                p1++;
            }
            else if(sum > n)
            {
                p1++;
            }
        }

        cout<<ans<<endl;
    }


    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值