sum of all integer numbers

sum of all integer numbers

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 0
描述
Your task is to find the sum of all integer numbers lying between 1 and N inclusive.
输入
There are multiple test cases.
The input consists of a single integer N that is not greater than 10000 by it's absolute value.
输出
Write a single integer number that is the sum of all integer numbers lying between 1 and N inclusive.
样例输入
3
样例输出
6

代码实现:(注意要区分n大于0和小于0的情况)

#include<stdio.h>
int main()
{
    int n;
    long i,sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        if(n>0)
        {
            for(i=1;i<=n;i++)
                sum+=i;
        }
        else
        {
            for(i=1;i>=n;i--)
                sum+=i;    
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值