PAT甲级.1125. Chain the Ropes (25)

题意

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.
两个绳子对折后再拼接
Your job is to make the longest possible rope out of N given segments.

输入格式

Each input file contains one test case. For each case, the first line gives a positive integer N ( 2<=N<=104 ). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104 .

输出格式

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

输入样例

8
10 15 12 3 4 13 1 15

输出样例

14

PAT链接


思路

每次取序列中最小的两个数,将各自取半相加后(用完删除)的新元素添加到序列中。如此重复,直到只剩一个为止
用最小堆实现,

代码

/**
* @tag     PAT_A_1098
* @authors R11happy (xushuai100@126.com)
* @date    2017-3-10 17:34-19:30
* @version 2.0
* @Language C++
* @Ranking  2240/409
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;

int n;
int insertFlag = 0;
vector<int> origin, res, insertion, heap;


void insertSort()
{
    for (int i = 2; i<n; i++)
    {
        if (insertion == res)
        {
            insertFlag = 1;
            sort(insertion.begin(), insertion.begin() + i);
            if(i>2) break;  //初始序列不参与比较
        }
        else
        {
            sort(insertion.begin(), insertion.begin() + i);
        }
    }
}

void percolateDown(int low, int high)
{
    int i = low, j = i * 2;
    while (j <= high)
    {
        if (j + 1 <= high && heap[j] <heap[j + 1]) j = j + 1;
        if (heap[i] < heap[j])
        {
            swap(heap[i], heap[j]);
            i = j;
            j = i * 2;
        }
        else
        {
            break;
        }
    }
}

int main(int argc, char const *argv[])
{
    int input;
    scanf("%d", &n);
    for (int i = 0; i<n; i++)
    {
        scanf("%d", &input);
        origin.push_back(input);
    }
    heap.push_back(-1);
    for (int i = 0; i<n; i++)
    {
        scanf("%d", &input);
        res.push_back(input);
        heap.push_back(input);
    }
    insertion = origin;
    insertSort();
    if (insertFlag == 1)
    {
        printf("Insertion Sort\n");
        printf("%d", insertion[0]);
        for (int i = 1; i<n; i++)
        {
            printf(" %d", insertion[i]);
        }
        printf("\n");
    }
    else
    {
        printf("Heap Sort\n");
        int p = n;
        while(p>=2 && heap[p] > heap[p-1])  p--;
        swap(heap[1], heap[p]);
        percolateDown(1, p-1);
        printf("%d", heap[1]);
        for (int i = 2; i <= n; i++)
        {
            printf(" %d", heap[i]);
        }
        printf("\n");

    }
    return 0;
}

收获

注意最小堆的实现
1. 建堆 percolateDown
2. 插入 percolateUp
3. 每次deleteTop之后记得percolateDown更新

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值